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Disclaimers 

 

1. TissueFAXSplus is a microscope-based cell analysis system for cells in cryocuts, paraffin sections 
and TMAs. It consists of the software modules “TissueFAXS”, “TissueQuest“, and “HistoQuest“ and 
is used for acquisition of images in the fluorescence and brightfield mode, for counting the number of 
positive and negative cells and for quantification of staining intensities. TissueFAXSplus is used for 
the standardization of tissue analysis in combination with immunohistochemical and 
immunofluorescence staining. 

The system does not give any direct diagnosis and there is the possibility that the samples do not 
contain enough information to give a clear diagnosis. 

The results of the analysis are purely statistical values. Users must re-evaluate images and likelihood 
of the statistical data. Pure interpretation of statistical data is a high risk. 

Observations: 

- TissueFAXS is similar to TissueFAXSplus but is for fluorescence samples only and must not be 
used with brightfield/immunohistochemical samples. TissueFAXS consists of the software modules 
“TissueFAXS“ and “TissueQuest“. 

- HistoFAXS is similar to TissueFAXSplus but is for brightfield/immunohistochemical samples only 
and must not be used with fluorescence samples. HistoFAXS consists of the software modules 
“TissueFAXS“ and “HistoQuest“. 

2. Each and any product should be used only after training performed by TissueGnostics or 
authorized distributors of TissueGnostics. A list of authorized distributors is available here: 

http://www.tissuegnostics.com/EN/distributors.php 

3. The names of actual companies and products mentioned herein may be the trademarks of their 
respective owners. 

4. In order to use TissueFAXS application, it is essential for the users to have sufficient knowledge of 
PC and Microsoft Windows operating system usage. 

5. The information from this document is subject to changes without notice. 

6. The information contained in this document is the proprietary and exclusive property of 

TissueGnostics GmbH except as otherwise indicated. No part of this document, in whole or in part, 
may be reproduced, stored, transmitted, or used for design purposes without the prior written 
permission of TissueGnostics GmbH. 

7. The information in this document is provided for informational purposes only.  

8. TissueGnostics GmbH specifically disclaims all warranties, express or limited, including, but not 
limited, to the implied warranties of merchantability and fitness for a particular purpose, except as 
provided for in a separate software license agreement. 

9. Copyright© 2006-2014 TissueGnostics™ GmbH. All rights reserved. 

10. Release date of this document: 13 April 2014 

11. Document version: 1.0 
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Notices about symbols and labels on product 

The following symbols appear on the labels of the product: 

 

 

 
Figure 1 - Product labels 

 

  Serial number  
  WEEE symbol / separate disposal of 

electrical and electronic equipment 
 

  Date of Manufacture  
 

  CE mark  
 

  Manufacturer  
 

 

 
 

Notice regarding anti-virus applications 

• All the TissueGnostics products are shipped with the Kaspersky Anti-Virus in order to ensure optimal 
functionality.  

 

• Therefore TissueGnostics only guarantees for Kaspersky Anti-Virus to work with its products. 
 
 

• The user may decide to use other anti-virus software only upon own responsibility.  
 

• Any problem that arises due to other anti-virus software installed will void TissueGnostics warranty and every 
support or service action required by the client in order to restore any of TissueGnostics damaged instruments 
will be billed to the customer. 
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1. Introduction  

1.1. Purpose  

The purpose of this document is to help the user understand how TissueFAXS works. It describes 
TissueFAXS software capabilities and also guides the user to the steps required to acquire high 
quality images. 

The document covers the installation of the application, system requirements and main features. 

In the next section you will read more about the goals of the application and its place in a larger 
system. You will also understand the purpose and the advantages of this application. 

1.2. Goals 

The user should use this manual as his primary source of instruction when using the application.  The 
functionality of all panels, menus and tools are explained in the following tutorials. 

At a glance, TissueFAXS provides: 

• Fully automated slide scanning; 

• Autofocus up to 100x Oil objective; 

• Multi-channel acquisition for fluorescent imaging; 

• High resolution image overview by TissueStitching; 

• Freely selectable areas of interest; 

• Channel overlay and data storage. 

Features of TissueFAXS’ automated image acquisition: 

• Slide readout; 

• Pre-scanning to identify tissue sections, smears and biopsies; 

• Multi-slide management and stage movement; 

• Self adjusting color and monochrome CCD/CMOS cameras; 

• Automated objective lens and filter block handling; 

• High-speed and high-precision autofocus; 

• TissueStitching for overviews of entire sections; 

• Time Lapse acquisition; 

• Channel overlay and data storage. 

TissueFAXS rapidly yields high resolution images of tissue sections for subsequent analysis in 
HistoQuest or TissueQuest (the cell analysis software for brightfield and fluorescent images, 
respectively).The process of image acquisition to data analysis and quantification is streamlined with 
the TissueGnostics software combination. Quick and easy data analysis in HistoQuest and 
TissueQuest is accomplished with these key features: 

• Powerful algorithms for image processing; 

• Automated identification of cells; 

• Analysis of staining intensities; 
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• FACS-style dot plot operations; 

• Backward connection from dot to cell; 

• Storage of virtual slide data and analyzed results. 

TissueFAXS enables the user to link all experimental image files with their corresponding data files 
into one convenient experiment folder. 

TissueFAXS supports upright and inverted microscopes from various manufacturers including Leica, 
Nikon and Zeiss. This manual was designed for the use with Zeiss microscopes, but it is transferable 
by a large extent to other supported microscopes. 

 

1.3. Definitions, Acronyms and Abbreviations 

This subsection provides the definitions of all terms, acronyms, and abbreviations required to 
properly interpret this Document. 

1.3.1 Definitions 

Term Definition Comments 

 - - 

- - - 

- - - 

1.3.2 Acronyms  

Term Definition Comments 

IKF Installation Kit Folder. The IKF is a folder where you find a set of 
executable files. These files are kits for installation of certain 
components. When you install TissueFAXS, you go to this folder 
and you find a list of executable files, which you must execute one 
by one. See Installation Overview for further information. 

- 

MTB Microscope Tool Box. The MTB from Carl Zeiss, a software 
component which gives an identical interface for all Zeiss 
microscopes under different operating systems. 

- 

1.3.3 Abbreviations  

Term Definition Comments 

 - - 

- - - 
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1.4. Conventions 

In this section you can find listed and explained the conventions used throughout this manual. 

 Note(s): describes important features or instructions. 

 Tip(s): highlights features or hints that can help you save time or avoid difficulties.  

 Caution(s): warns readers about possible damage to equipment or to data or about 
potential problems in the outcome of what is intended. 

Italics: are used in order to highlight a title and also new or unfamiliar terms, usually at their first 
appearance in the text. 

Bold: are used in order to highlight important terms or to mark the names of the features/GUI 
elements throughout the text of this manual. 

→: the arrow indicates a menu choice. For example, choose “File → Save as template” means you 
have to choose Save as template from the File menu. 
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2. Installing TissueFAXS 

2.1. Installation Overview 

Where do I find the installation kits for the required components? 

Usually, the TissueFAXS installation kit is provided with a set of other installation kits for the rest of 
the components, which can be found in the same folder. Most of the components are also found on 
official websites. You need an internet connection in order to download those components. 

In order to make the installation procedure easier, you are provided with a folder where you find all 
required kits. Install them in any order you want, but make sure TissueFAXS is the last one to be 
installed. If you are not sure how to start, try this order: 

1. .NET Framework 4.0 Runtime; 
2. Microsoft Visual C++ 2012 Update 3 Redistributables; 
3. Intel Performance Primitives 7.0; 
4. MTB RDK 2.1.0.8; 
5. TissueFAXS. 
 

 

- TissueFAXS software will not run and operate properly if any of the components is not 
installed on your TissueFAXS workstation. 

- Installing software programs and Windows system components will require 
Administrator privileges on your computer. You might need to ask for support at your 
IT department if you do not have privileges to install software. 

 

2.2. .NET Framework 4.0 Runtime 

Parts of TissueFAXS product rely on version 4.0 of .NET Framework which can be also found at the 
Microsoft official website. 

The Microsoft .NET Framework version 4.0 (x86, x64) redistributable package installs the .NET 
Framework runtime and associated files required to run applications developed to target the .NET 
Framework v4.0 (TissueFAXS is such an application). 

For further information about this package please visit the Microsoft homepage. 

2.3. MTB RDK 2.1.0.8 

You find this kit in the Installation Kit Folder (IKF) of TissueFAXS. 

TissueFAXS requires this installation to communicate with the microscope. 

Below are some features of the Micro Toolbox (MTB): 

• Gives an identical interface for Carl Zeiss microscopes under different operating systems; 

• Has high level functions for controlling the components; 

• Gives information about the equipment (e.g. which objectives and reflectors are mounted); 

• May simulate devices: programming and demos are possible even without hardware. 
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- For problem solving and re-installation, it is essential that you configure your 
microscope in terms of “teaching” it which hardware is provided. To do so we 
recommend using the MTB configuration tool.  

- The TissueFAXS instrument you received from TissueGnostics or your local 
distributor has been preconfigured and you should not change anything in this 
configuration, unless you encounter technical problems and you are directed by the 
support team. 

 

2.4. Intel Performance Primitives 7.0 

Intel® Integrated Performance Primitives (Intel® IPP) is a software library for application developers, 
providing better performances on Intel’s latest microprocessors. Incorporating these functions into the 
TissueFAXS software will ensure that the potential of your Intel-based PC can be fully exploited for 
analysis of your samples. 

2.5. Microsoft Visual C++ 2012 Update 4 Redistributables 

The Visual C++ Redistributable Packages install runtime components of Visual C++ libraries that are 
required to run applications developed using Visual Studio 2012 on a computer that does not have 
Visual Studio 2012 installed. These packages install runtime components of the C Runtime (CRT), 
Standard C++, ATL, MFC, C++ AMP, and OpenMP libraries. 

http://www.microsoft.com/en-us/download/details.aspx?id=30679 

 

TissueFAXS contains modules that were developed with Visual C++, so this Redistributables kit is 
required. 

 

The TissueFAXS instrument you received from TissueGnostics or your local 
distributor has been preconfigured and you should not change anything in this 
software /hardware configuration, unless you are directed by the support team. 

 

For further information about this package please visit the Microsoft homepage. 

2.6. TissueFAXS 

The TissueFAXS installation kit is the last file installed from this list of required components. 

It consists of a single executable file. Once launched, it leads to a well-known installing procedure. 

You just need to run it and follow the instructions. 

Mainly, you have to choose the destination directory and that’s all. 

An important feature is that different versions of TissueFAXS may coexist on the same machine. 

You only need to make sure that they are installed in different directories. 

If you want to install the same version of TissueFAXS in the same directory, please uninstall the 
existing version first, instead of overwriting it. This ensures that no files are in use and the new 
installation will be a fresh new one. 

Also note successive installations of TissueFAXS do not require re-installation of the other 
components as well. Once installed, the other required components work independently of 
TissueFAXS and keep working, unless you have uninstalled each one by one. 
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TissueFAXS is ready to use when all components are installed and there are no error messages.  

Firstly, turn on the hardware: turn on the microscope and the UV-lamp, if required.  Secondly, turn on 
the computer and run TissueFAXS. 

2.7. System Requirements 

2.7.1 Hardware Requirements 

Minimum  

• Intel Core2Duo Quad Processor - 3 GHz (or more)  

• 4 GB RAM 

• Internet connection (for update)  

• USB-Port (for dongle) 

• 500 GB  free hard disk space for storing your projects 

• Monitor system with a resolution of 1280x1024 (or higher) 
 

Recommended 

• Intel I7 Quad Processor - 3 GHz (or more)  

• 8 GB RAM 

• Internet connection (for update)  

• USB-Port (for dongle) 

• 1000 GB hard disk space for storing your projects 

• Dual monitor system with a resolution of 1280x1024 (or higher) 

2.7.2 Software Requirements 

• Windows 7x64 

 

 

Notice regarding virtual machines  

TissueGnostics software is not meant to work on virtual machines. Also, TissueGnostics does not 
offer support for these configurations, as the software directly uses advanced CPU features and 
therefore any third layer between the software and the CPU will affect performance and might affect 
the results of the analysis in an unpredictable way. 
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3. Starting TissueFAXS 

3.1. Login Dialog 

After starting the application, a login panel will appear.  

 

Figure 2 - Login Panel 

 

In order to login to TissueFAXS, please enter a username into the User Name field and type the 
proper password into the Password field.   

Press I Agree and Login to be authenticated. By pressing this button you explicitly agree to the 
TissueGnostics Disclaimer.  

If the username and password are correct, the login dialog will close and you can start using the 
application. Otherwise, the application will prompt again for a valid username and password 
combination.  

If you press Cancel, the login dialog and the application will close. 

The login dialog is used to restrict access to the application. There is one Administrator and any 
number of users, who may be managed when the Administrator is logged on (for more details please 
see Chapter 4.8). 

On the Login panel there is also the Profiles button. For more details please see Chapter 4.6. 
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Figure 3 - Profiles feature 

3.2. Splash Screen 

The Splash Screen appears while TissueFAXS loads and establishes communication with the 
hardware components (microscope, stage, cameras). 

 

Figure 4 - Splash Screen 

3.3. Device Calibration 

To start an image acquisition, please choose to calibrate the stage when starting the application. You 
may choose to skip this step if you simply want to view previously acquired images in TissueFAXS.  If 
you later decide to perform acquisition, you will be prompted to calibrate the stage at that time. 
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Stage calibration is important for acquiring high quality stitched images, as well as the protection of 
the hardware components from physical damage. During the calibration, the application finds the 
hardware limits with extreme precision. You will see the objectives and stage moving automatically, as 
the system measures the coordinates of the stage in relation to each objective (in nanometers). 

To initiate the calibration procedure, press Continue. 

 

Figure 5 - Stage Calibration warning message 

    If the magnification of the calibration objective is higher than 20x, a warning message will appear. 
In this situation there are two options: 

 

Figure 6 - Calibration objective: warning message 

 

• Press Cancel calibration, then go to Tools → Options → Application Options → Actions → 
Calibration in order to select another objective from the dropdown list, then return to calibration 
process from Tools → Calibrate stage... For more details, please see Chapter 4.1.1. 

• Press OK to continue calibration. 

 

- Please consider that if you continue the calibration as described above, you should 
think about the risks, such as damages to your objective, stage or slides. 

            

After the calibration ends, TissueFAXS is ready to be used. You can now create new projects, open 
existing ones, or simply adjust the microscope components and see live images from the camera, as 
described in the following chapters. 
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4. Options 

The Options panel is very useful in managing the main utilities of the application. Here, by accessing 
the listed items, you can visualize the available settings and also modify them according to your 
needs.  

You can find the Options panel by going in Tools → Options or by choosing Options button ( ) in 
TissueFAXS main toolbar.  

 

Figure 7 - Options Panel 

 

4.1. Application Options 

4.1.1 Actions 

This section contains several important actions concerning the interaction between TissueFAXS and 
the other components of your system: the computer and the microscope. 
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Figure 8 - Actions dialog 

Acquisition 

After finishing the acquisition, three actions can be performed: 

• Beep after acquisition: TissueFAXS will announce the finish of the acquisition process by 
repeated beep sounds; 

• Shut down after acquisition: the computer will automatically shut down after acquisition. 

• Acquire Correction Image: before the acquisition process, a correction image will be 
acquired. 

Safe distance 

Safe distance means the Z-position to which the stage is lowered in order to ensure that no objective 
lens collides with the slides or any part of the stage. 

Safe distance is used in the following situations: 

• calibration of the stage; 

• when moving between slides. 

 

- By default, for any objective with magnification higher than 20x, TissueFAXS will lower 
the stage  to the safe distance. For the rest of the objectives, you may customize this 
behavior in the dialog shown below. Usually, you will prefer to enable this behavior for 
any longer objective or for objectives that come very close to the slide for focus. For 
inverted microscopes, the best action is to enable it for all objectives. 

 

Calibration 

This is a safety setting and you should access it after installing TissueFAXS in order to choose a safe 
objective for calibration. This choice means that the application is helping you avoid possible 
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damages of the objectives, stage or slides, caused by an inappropriate objective being used during 
the calibration procedure. 

If an objective with a magnification higher than 20x will be selected for calibration, every time before 
performing calibration TissueFAXS will send you a warning message (please see Chapter 3.3). 

Cache 

The image cache consists of scale down acquired images and it is used to speed up the display of big 
regions and decrease the memory requirements for this operation. If no cache is built, you will be able 
to see only low resolution images.  

 

Other operations like export and analysis are not affected in any way by 
the presence or lack of the cache. 

 

The cache can be built: 

• By choosing one of the options from the Build Cache dropdown box (please see image bellow) 

 

- Never: Cache won’t be built during acquisition. This will slightly decrease acquisition time. Only in case of regions 
larger than 1000FOVS the decrease will be noticeable.  

- During acquisition: As each FOV is acquired it will be processed and smaller versions of it will be created. For big 
regions might increase the total acquisition time and also the GUI will respond slower if the region is opened. 

- After acquisition: if the cache is performed at the end of the acquisition process, a progress bar will inform the user 
about the status of the action (please see image below). This will increase the acquisition time by 10 to 15 percent.  

 

Figure 9 - Build cache after acquisition - Progress bar 

• When opening a region, if Tools → Options → Actions → Use default cache action for regions without 
cache is checked and Build Cache is set for Default Cache actions. 

 

If Use default cache action for regions without cache is not 
checked, TissueFAXS will ask every time when opening a region 
without cache if you wish to build it. 

 

• Using the region contextual menu Build Cache for Region […]. 
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Figure 10 - Build cache feature in region contextual menu 

4.1.2 Licensing 

In the Licensing dialog the user will renew the license for TissueFAXS by following these steps: 

• use Save license file… button in order to save the license file on your hard drive; 

• send this file to your local TissueGnostics distributor to be renewed; 

• use Load license file… to reload the new license file to the application. 

 

- Please use the Licensing feature ONLY if you are instructed by TissueGnostics 
personnel or authorized distributors. 

- Licensing feature is only available if logged as technician or administrator. 

 

 

Figure 11 - Licensing dialog 
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4.1.3 Measurements 

In the Measurements dialog you can manage the display options for the scale bar and measure 
function.  

 

Figure 12 - Measurements dialog 

 

Scale bar  

The Scale bar icon looks like this: . 

The Scale bar is represented by a segment that indicates the scale of the image. 

It has two adjustable attributes: 

• The color; 

• The location list with four values:  

 

Figure 13 - Scale bar location combo box 

 

- The default values are Black (for color) and Bottom Right (for location). 
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The scale bar can be found on: 

- Live Image; 

- Slide Preview; 

- Region Viewer; 

- One Image Viewer; 

- Exported Images.  

 

Measure 

The Measure icon looks like this: . 

This function is used to measure the distance between two points (on the sample) specified by the 
user (by clicking on the start point, then on the end point).  

The distance and the unit of measure are displayed on the measured image. 

 

Figure 14 - Measured image example 

 

- There are two adjustable attributes, the color and the measure unit. The default color is 
aquamarine and the default measure unit is millimeter. 

 

This function is available on: 

- Live Image; 

- Slide Preview; 

- Region Viewer; 

- One Image Viewer. 

RGB  

Here you can select the color used to display information about RGB or Grey value for a pixel on the 
camera live image. 
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4.1.4 Remember 

 

 

Figure 15 - Remember dialog 

This dialog can be used to specify default values for some of the most commonly used options of 
the application. 

• Uncheck Do not show preview focus dialog again if you want that dialog to be displayed 
before the preview operation; otherwise, check this option; 

• Uncheck Do not show reset focus point for preview dialog again if you want that dialog to be 
displayed when you reset the preview focus points; otherwise, check this option. 

• Do not show slide renaming dialog again: this option (checked by default) will prevent the 
slide renaming dialog to appear each time you create a new experiment. 

• Time Lapse Acquisition: check this option in order to set by default multiple acquisitions for a 
region or a group of regions. Please set desired values for the following parameters: 

- Number of runs: how many times the acquisition will run; 

- Time lapse: the interval between runs.  

 

• Acquisition e-Mail Report: this feature allows the user to be notified by email when the 
acquisition process ends. This is especially useful when acquiring very large areas of tissue with 
many FOVs. In order to enable this option, check Send e-Mail after acquisition finishes 
checkbox. You must also fill in the information regarding the SMTP server and the e-Mail 
address. Once you fill in this information, TissueFAXS will remember it for further use. 
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4.1.5 Support 

When using TissueFAXS, as in any other software application, you might occasionally encounter 
different kinds of errors, or you might simply need support and answers to your TissueFAXS related 
questions. The Support section was designed to help you in these situations. 

 

Figure 16 - Support dialog 

Enter the following information for dynamic error reporting: 

• The real name of the user who bought the software (e.g.: institution name); 

• The email address that will be set as sender; 

• The email address of Tissue Gnostics support; 

• The available SMTP server/port to be used when sending the error report. (Contact your network administrator 
for details).  

Use Submit Command: check this in order to access an external executable file that will send the 
files to a server.   

Auto Save Report: check this option in order to save the log files on the hard drive, no matter if the 
report is sent or not. 

Test Connection is used to see if the connection to SMTP server works. 

Submit Report will help you send a mail containing your possible questions or problems regarding 
TissueFAXS. Beside the information you type in the form, the email automatically includes the log 
files, the running processes, and the configuration files of the application. To effectively send the mail, 
press the Send Report button. 
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Figure 17 - Submit Report dialog 

Generate exception is used to simulate an error in order to test if sending emails with the specified 
settings works. 

 

Figure 18 - TissueFAXS Error dialog 

- Error description: here you can see a short description of the error. 

- Error detail: here you can find detailed data related to the error. 
 

Open Reports Folder: if a report is not sent, it will be automatically stored in a local folder; press 
Open Reports Folder to open that folder. 

Send Saved Reports: press this button to send all unsent reports, if any. After effectively sending 
saved reports, they will be automatically deleted from the local folder where they were stored. 
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Product Improvement Program 

Product Improvement Program checkbox: In the Product Improvement Program, participating 
systems send information to TissueGnostics about how they use certain products. Received data is 
combined to help TissueGnostics solve problems and to improve the products and their features. 
Click the link in the lower-left corner of the dialog shown above to read about this program and check I 
agree checkbox if you want to participate. If you don’t check the check-box, the Send Error button 
will be disabled. 

 

Figure 19 - Product Improvement Program Agreement  

4.2. Default Experiment Settings 

4.2.1 Preview 

 

In the preview dialog you can manage the stored preview schemes. The adjustable yellow area allows 
the user to define the default preview region on the slide(s). 

 

Figure 20 - Preview dialog 
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• By default, four preview schemes (All Slide, Large Center, Normal Center, Small Center) 
are present, which cannot be deleted or modified. These schemes are grey. You can add, 
rename or delete additional schemes from this panel. 

- Create new preview area on slides: press Add… button to create a new preview schema 
according to the size and the location of the sample you are currently using. After giving a 
name to the newly created preview area, you can modify its size (resize using the mouse 
cursor on any edge of the shape) or move it (by using the mouse cursor to drag & drop the 
area to the desired location); 

- Set the default preview area on slides by selecting the desired entry from the Preview 
Schema combo box. 

• Select the label position from the Label Position section (default label position is down).  

 

- The options mentioned here will only affect newly created projects. Please remember 
the label position is not stored in the preview schema.  

- Changes in this panel will affect future experiments. If you want to change the preview 
area of a current experiment, use the Preview option from the Experiment Options 
section (in the same dialog). 

 

4.2.2 Reflectors 

Fluorescence images are usually gray scale images (from black to white over a certain number of 
gray values), the intensity of the gray values representing a certain marker staining intensity. In order 
to acquire a marker, a corresponding reflector (filter block) must be used. When using multiple 
markers, in order to get a better overview for the entire region, TissueFAXS allows you overlaying 
images acquired with different reflectors. You can choose for each reflector (color channel) the 
optimal color (Look-Up Table) that will represent the corresponding marker in the final image.  

 

 

Later on we will use the following terms:  

- A Region Overlay is the image created by superimposing images of the same region 
acquired with different reflectors. 

- A channel is the image of a region acquired with a certain reflector. 

 

The user has also the option to change the names of the reflectors by going to Tools → Options → 
Reflectors. 

The colors of the reflectors will be used as default for new experiments only and after acquisition each 
region can have its own color configuration.  

You can edit these default colors according to your needs in the dialog below (see also Chapter 
6.4.2): 
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Figure 21 - Reflectors dialog 

• Use inverted image for Transmission channel, in case of fluorescence experiment:  choose 
how the transmission image will appear in the overlay image - the normal image or the inverted 
image of the Transmission channel (which means a ‘’fluorescence-like’’ appearance); 

• Use white in preview overlay of fluorescence slide: for fluorescence experiments, if only one 
channel is present in the preview settings, the default color for that channel is white. If the 
preview is made on a nuclear marker like DAPI and is displayed in dark blue, the resulting 
preview image will be difficult to see against the black background. White, however, gives a 
stronger contrast. 

• Finally, you can choose how the name of the reflector will be displayed in the application: Full 
name, Short name or Abbreviation (see also Chapter 6.4.2). 

4.2.3 Storage 

In the storage section you can define various data for the file to be stored, like the file names 
convention, the file types and the default locations. 
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Figure 22 - Storage Settings dialog 

 

• Name Parts: select  the parts that will generate the filename ([Experiment], [Region], [Field Of 
View], [Filter]); 

• Parts Separator: select the separator between the parts of the filename; 

• Image Format: select the image file format (e.g.: .jpg for small file size and good quality, .bmp 
for large file size and high quality); 

• Store each slide in a separate directory: select how to organize image files in directories; 

• Store each region in a separate directory: select the default directory in which the projects 
will be stored; 

• Raw Data: check Save raw data if you want to save the raw data image corresponding to your 
file. 

 

-  Important: Please avoid storing projects on Desktop, My Documents, or in any other 
folder located on the system drive (usually C). If the drive is nearly at its full capacity, 
the system might behave erratically or even stop working if the drive completely runs 
out of space. Usually, systems delivered by TissueGnostics have a dedicated storage 
medium for projects; it is advisable to use it in order to increase TissueGnostics 
products performance and avoid issues with low disk space. Also in case the system 
needs to be reinstalled (virus infection, system files being deleted) you might lose data 
located on the system drive. 

- BMP files  are uncompressed images which will take lot of space 

- For best quality/size ratio we recommend saving as TIFF/PNG 

- JPEG files offers the best compression ratio, but the quality of the images will be 
decreased 
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- Some antivirus software might scan image files, thus increasing acquisition time. 
Check with your local administrator on how to exclude project directories from 
scanning. Systems delivered by TissueGnostics do not have this problem.  

 

4.3. Scan Settings 

4.3.1 Scan Strategy 

TissueFAXS provides a type of Scan Strategy (Snake) that allows an optimal scanning process. 

 

Figure 23 - Scan Strategy dialog 

• Use software backlash correction: This is a feature that helps avoiding certain errors that 
may appear when changing the moving direction of the stage (caused by physical 
caracteristics of the stage), which is the case during normal TissueFAXS operation. It 
applies only to XY axis of the stage. The stage precision will be improved but, as drawback, 
the acquisition time could increase with as much as 30%. The backlash correction should be 
used when the acquired images do not properly fit to each other. Note: If all the images have 
a stitch problem, you should check the FOV calibration settings. 

 

- Important: Use this only if instructed by TissueGnostics support time. Leave this 
uncheck otherwise.  
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• Use Enhanced Camera Mode: this is a feature available on few cameras that will increase 
data transfer speed. 

• Well Plates and TMA Optimizations: This is a feature that allows the user to specify the 
maximum number of FOVs that will be acquired for WellPlate regions and TMA Spots.  In 
order to do so you must check the option then chose one of the predefined values for FOV 
Rows and FOV columns. 

• Focus only once per TMA spot: due to the fact that a TMA spot is quite small, a single 
focus action would be usually enough, in order to reduce the acquisition time. However, in 
case you deal with a larger TMA spot, you can uncheck this option to ensure that the entire 
tissue will be in focus.  

4.3.2 10 Stitching 

Stitching will allow the user to see high quality pictures without any inconveniences caused by stage 
errors, camera calibration or other issues that might interfere with proper image display/acquisition.  

To enable this feature you must mark the Enable Stitch checkbox.  

 

Figure 24 - Stitching dialog 

 

You can choose between internal and external stitch: 

Acquire with overlap only (For external programs): The acquired images will share common parts 
with their neigboring images. Use this option only if you want to stitch the images using third party 
stitching software. For normal use of the TissueFAXS software this is not recommended. Be also 
aware that regions acquired with overlap can’t be properly handled by HistoQuest. 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 32 of 211 

 Internal 
 

Use internal stitch: TissueFAXS will determine, based on the settings from Stitch options (see 
below), how to stitch the FOVs in order to obtain region overview without any discontinuities. 
HistoQuest will be able to properly handle this kind of regions. 

Overlap settings: the external and internal stitching will properly work if the regions are acquired with 
an overlap that will allow compensating hardware errors. It is recommended using a value of at least 
15 %. Avoid acquiring regions with large empty areas when using stitching. 

Width/Height Overlap: are used to specify the percentage of width/height that will overlap 
neighboring FOVs. 

Stitch options 

 

Figure 25 - Stitch options 

 

Compute stitch mode:  

• Manual: speeds up the acquisition process. However, the user will have to manually call the Compute Stitch 
option. 

• During  Acquisition: slows down the acquisition process; the user will be able to see the acquisition results in 
real time. 

• After Acquisition: this option will call the stitch after each region has been acquired. 

 

Min allowed stitch score: decrease this value only if you are acquiring regions with a large empty 
area. In any other cases you should let it to the default value. 

 

- Important: Stitching will not be able to compensate for major hardware errors 
(defective stages) or major errors in configuration (FOV sizes, rotated cameras).   

 

4.3.3 Focus 

In this section you can adjust all the focus relevant parameters, organized in two tabs: Focus 
Options and Enhanced Focus.        
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Focus Options tab                                                                                                                                         

 

Figure 26 - Focus Options tab 

 

Focus Search Algorithm 

- Manual focus: when using this type of focus, the user will be prompted to manually focus 
the image when necessary. 

- Current position: no type of focus will be performed and the stage will maintain the same 
focus position for all FOVs during acquisition. 

- Autofocus: when using this type of focus, TissueFAXS will automatically detect the best 
focus position, based on the parameters you can find described below. 

 

The Autofocus method consists of two steps. In step one, using a fast method, TissueFAXS tries to 
determine a short interval where the focus is best. In step two, using a high precision method 
(specified by the Fine Focus Measure parameter), TissueFAXS determines the best focus position 
from the fine focus interval determined in step one.  

Generally, in order to determine the fine focus interval, TissueFAXS uses the Rough Focus 
Measure and scans the entire interval specified in the “Focus interval” section. This approach is 
called “Full Focus”. 
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However, in order to improve the speed of the focus, if a previous focus position was found, 
TissueFAXS will directly use the Fine Focus on a small interval around the last focus position. This 
approach is called “Quick Focus”.  

 

- If the Quick Focus method fails, a Full Focus will be automatically performed. 

 

The following parameters are for autofocus only and have no effect on the Current position or 
Manual Focus. 

 

Rough Focus Measure and Fine Focus Measure 

For both Rough Focus and Fine Focus steps, three focus measure algorithms are available:  

• Variance: this is the fastest and most robust method for finding the location of the sample. It has 
the drawback of being easily affected by the quality of the samples (e.g. any dirt, bubbles of air in 
the oil – if any, illumination problems or any other optical artifacts). This method is the default 
choice for Rough Focus measure because its robustness and speed.  

• HP: this method is more precise than Variance at the cost of being more time consuming. It has 
two additional parameters, X% and Y%, which specify how much from the image is processed. 
By decreasing these two values the speed of the HP will be increased, at the cost of lowering the 
chance to focus on sample (e.g. analyzing a hole of the tissue cannot provide the Z position due 
to lack of signal). Usually, a value of 50% or above should provide a good balance between 
speed and accuracy for objectives up to 63x. For higher objectives, it is recommended to have 
most of the image content analyzed. This method is the default choice for Fine Focus 
measure. 

• HP Fine: this method is the most slow (more than two times slower than HP in terms of 
computing time), but it can provide the best focus under toughest conditions. It should be used 
only when HP fails repeatedly on difficult samples, for example on fluorescence samples with a 
high un-uniform background. This method is not recommended for Rough Focus. It has an 
additional parameter (if compared to HP): the Resolution. Its default value is 25 and is related to 
the size of the relevant objects in the image. Setting this value lower translates into higher focus 
sensitivity, also for small objects. 

 
Focus Strategy Neighbors 

This parameter can be adjusted according to the flatness of your tissue section, as the focus directly 
depends on the subsidence of the tissue. If the tissue section would have been perfectly flat, a single 
focus for its entire surface would have been enough. But more often, each tissue section has its own 
relief and the focus must be performed repeatedly. The higher the magnification will be, more the 
relief will influence the focus. 

The Focus Strategy Neighbors helps you save time when performing the focus, by avoiding 
unnecessary focusing. The regions to be acquired will be split in blocks of Fields of View. The Focus 
Strategy Neighbors parameter defines how many FOVs will share the same focus estimation.  In the 
actual example, 3x3 is selected, in which case TissueFAXS will focus once for every block of 3X3 
fields of view. (The location of the focus point within the block is determined based on the Focus 
Points parameter).  After focusing in one point, TissueFAXS will scan all neighboring FOVs using the 
same focus position.  

• Focus Points: 

- Fixed Focus Points: the focus is performed on the FOV from the center of the block 
determined by the Focus Strategy Neighbors. Fixed Focus Point is the most frequently 
used in the acquisition process, when your tissue sample is compact (without holes, for 
example); 

- Floating Focus Points: the focus is performed in a point that may not be the center of the 
block. Floating Focus Points are especially used for biopsies or when your regions to be 
acquired are not compact (e.g. they include holes). The method identifies the location of the 
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tissue within one block of FOVs and selects the most inner one. This location may be 
between several FOVs and not necessarily identical to one of FOVs. 

• Always force full focus: The last focus position is ignored and the focus is always searched in 
the full interval. This method will take more time, but the obtained results will be better in case 
of difficult samples and environment (e.g. samples with many tissue folds).  

 

Focus Validator 

The Focus Validator checks and confirms that the focus search algorithm has obtained a good 
quality image.  

It is used to confirm that the Quick Focus method has worked fine. If the quality score it provides is 
low, then a Full Focus search is initiated. 

It is also used to confirm that the Full Focus method algorithm has obtained a sharp image. If this 
validation fails, the system will use the last known good focus position.  

Normally, the default values for the validator options should be enough to provide a good acquisition.  

- Disable focus validator: it will disable any focus validation and, as a consequence, any 
images returned by the focus algorithm will be accepted as being in focus. It should be used 
only as a last solution when the sample has a very low contrast.  

- Maximum allowed score: increases the tolerance of the focus validator. Setting low values 
means that only very good images will be accepted as being in focus. Setting high values 
means accepting lower quality images (e.g. blurred). Basically, this parameter should be 
increased when using samples of a lower contrast.    

- Fidelity of details (pixels): size of relevant details. If you set it to minimum (3), then finest 
details are searched for and will make a difference in the validator score. If you set to 
a higher value, then only rough elements will count in computing the score. However, this 
depends on the images you are processing. Most of the time, the default value should 
provide good results.  

 

The Load default settings button restores the default options only for the focus validator settings. 

 

Focus Interval 

In this dialog you can specify the z-boundaries of the rough focus-search. You can adjust your focus 
search interval to match extra thick or thin cover slips or culture plates. To determine the proper focus 
interval, we recommend manually focusing with the objective of interest. You can then check the 
current Z-position in the camera window and add 250 µm above and below this position for the upper 
and lower Z-positions of your interval. The current Z position should be read from TissueFAXS 
software (in Camera window) and not from any display of the microscope. Larger focus intervals will 
make the autofocus slow and may cause the microscope to focus on objects laying on the cover slip. 

Set around this point button ( ) is meant to automatically set the Z interval 
within +/- 200 around current Z position (the position where the tissue is in focus), in order to restrain 
the focus interval and to reduce the duration of the focus process. 

 

- If you want to use the specified focus interval for all objectives, check Override default 
intervals with these values; 

- If you want to use the default focus interval only, uncheck Override default intervals 
with these values. 

 

 

- Please be always very careful when making focus related changes, as wrong settings 
could cause damage to your sample and your objectives! 
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- For all the items described in Focus section, some tool tips are available. This means 
that when the mouse is over an item, a short description of the respective item will 
appear. 

 

 

Enhanced Focus tab 

The options from Enhanced Focus tab will increase the speed of the focus. However, they are 
available only on certain cameras.  

Focus Distance: This option will allow you to specify the distance for which a focus position will be 
used thus decreasing the time needed to focus. This option must be used only for TMA or any other 
small regions that are close to one another. The distance parameter can be determined using the 
measure function on the slide preview.  

Enhanced Camera Mode: it will increase data transfer speed. 

 

Figure 27 - Enhanced Focus tab 
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4.3.4 Advanced Focus 

 

Figure 28 - Advanced Focus dialog 

TissueFAXS software is shipped with one default extended focus method - Default - that works for all 
reflectors.  

Z Stack 

Z Stack represents a set of images that are acquired above and below the optimal focus position. By 
combining these images, a final FOV image will result, containing a higher level of details than any of 
the initial Z Stack. 

Check this option only if you intend to use some external software to fuse the images. Be aware that 
enabling this option will require more space on the hard drive. 

You can choose to use the Z stack for each individual reflector by marking the corresponding 
checkbox from the Save Z Stack column.  

 

- To be able to use the Z stack for individual channels, you must previously check the 
Save Z Stack option below the reflectors’ section. 

 

 

Use Extended Focus 

For each reflector present in the system, you can choose the extended focus method used to 
combine the Z Stack. 

Check this option only when objects are present on multiple focus plans. 

If you don’t want to apply the extended focus to one or more reflectors, choose None option from the 
reflector’s dropdown list. 
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 Figure 29 - Reflectors: Extended Focus dropdown list 

 

Extended focus options 

You can specify the number of steps above or below the automatically computed focus position and 
also the step size. 

 

 

- To be able to use the extended focus for individual channels, you must previously 
check the Use Extended Focus option below the reflectors’ section. 

 

 

- Using any of the two options (Use Extended Focus, Save Z Stack) will significantly 
increase the acquisition time. 

4.3.5 Speed 

In the speed dialog box you can adjust the speed of stage movement during acquisition. These 
settings do not affect the speed settings of your joystick. Generally, all speed values can be set to 
maximum. However, if you are working with well plates or cell cultures in general, you may want to 
reduce these values (in order to avoid troubling the content). 

The Acceleration parameter describes how fast the stage will try to reach the defined speed.  

 

Figure 30 - Acquisition Speed dialog 
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4.4. Hardware Settings 

4.4.1 Camera Manager 

This option allows you to add and remove a camera from the list of the cameras connected to the 
computer. It also helps you setting the current camera. For more details please see Chapter 6.6 of 
the current manual. 

4.4.2 Contrast Manager 

The Contrast Manager is an automated feature of the software that will automatically adapt the 
contrast method of the microscope based on the type of experiment you are currently working on.  

 

Figure 31 - Contrast Manager dialog 

The Contrast Manager has three options available in the dropdown box shown below: 

 

Figure 32 - Contrast Manager options 

• Default: TissueFAXS won’t try to set the contrast method of the microscope. For optimal 
results, we recommend manually setting the contrast method on the microscope. 

• Smart: TissueFAXS will set the contrast method according to the type of experiment. This is 
the recommended setting for the Contrast Manager.  

• Off: TissueFAXS will disable the Contrast Manager of the microscope. Use this option if 
Default and Smart options don’t return desired results. 
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- If the contrast method is not available for the microscope, it will revert to bright field. 

 

 

- For a detailed view over contrast manager and contrast method, please consult your 
microscope operating manual. 

 

4.4.3 Stage Manager 

This option is useful only for inverted microscopes or for any other kind of system that can support 
different types of stage inserts (slides, well plates, flasks). You can choose here the layout of the 
stage (later referred as stage configuration) for the next experiment.  

 

Figure 33 - Stage Manager dialog 

TissueFAXS supports switching at runtime between different stage configurations.  At this point, 
two base configurations are supported: 

• Slide inserts: a slide insert is usually defined by the maximum number of slides it can hold, by 
slide dimensions and distance between two consecutive slides. This type of configuration can be 
used on an inverted microscope for culture flasks as well. 

• Well plate inserts: a well plate insert is usually defined by the number of wells per row and 
column, distance between two consecutive wells and the distance from the edge of the plate till 
the first well. 
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- TissueFAXS is configured by default with a slide insert configuration for 4 or 8 slides 
inserts.  

- In order to control the defined slide inserts or to change the active one you must 
choose Tools → Options → Stage Manager. 

 

Using stage configurations 

Drop down box ( ) is used to select the 
desired insert configuration.  

The area below contains information about the current configuration.  

Example 1: The default configuration of the stage: 

 

Figure 34 - Stage Manager: Default Configuration section 

 

Example 2: Information for a well plate: 

 

Figure 35 - Stage Manager: Well plate section 

 

After you have selected the desired configuration you must click on the Active checkbox near the 
dropdown list.  

Once you’re done, you must press Save and Exit. Any existing experiment will be saved and closed. 
The selected configuration will apply only to newly created experiments. 
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Creating new configurations 

In the drop down list with the available configuration, click on the entry New.... 

 

Figure 36 - Creating new configurations combo box 

At this point, the Create template dialog will open. It contains two options: 

1. Create template based on an existing template 

 

Figure 37 - Create well plate template dialog 

A new window will appear. Note that information about the selected template is displayed below in the 
drop down box (our example shows a well plate insert). 
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Figure 38 - New stage configuration: Select template dialog 

 

At this point, you must choose one template from the available templates and click Next. 

You must now specify the distance between the 0,0 point of the stage and the leftmost edge of the 
well plate, respectively topmost edge point of the well plate (actually the Stage X Origin Offset and 
Stage Y Origin Offset parameters, that you can see in the image below).  

The Alpha parameter represents the skew angle of the well plate insert related to the stage (usually, 
this parameter is 0). 

Performing this configuration for the well plates will make sure that the default regions created by 
TissueFAXS will match the actual well plates on the stage.  



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 44 of 211 

 Internal 
 

 

Figure 39 - New stage configuration: Additional Parameters dialog 

 

 

- In case of slide inserts, the distance is computed between the 0,0 point of the stage 
and the first slide on the insert. 

 

Once you’re done, you can select the newly created configuration using the previously described 
steps. 

2. Create new well plate template 

By choosing New well plate template ( ) from the Create template dialog, 
you will be guided by a wizard to setup TissueFAXS for using a well plate insert. 
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Figure 40 - Create well plate template: Wizard 

Step 1: here you must choose the name and the type of the template to be created. For the well plate 
type, some options are already available by default, but you can also create a new type by choosing 
Custom option from the dropdown menu. 

 

Figure 41 - Create well plate template: Wizard, Step 1 
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In the next steps of the wizard (2-9), simply follow the indications given for each step (see figure 
below). 

 

 

Figure 42 - Create well plate template: Wizard, Steps 2-9 
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- Once you have created a well plate experiment and added the well plate regions, you 
can control their size and position in a similar manner as described in the TMA chapter 
(please see Chapter 7). 

- After creating the well plates templates, they will be available for further use in the 

Drop down box ( ). 

4.4.4 Load Settings 

 

Figure 43 - Load Settings dialog 

 

The user can use this feature to load the settings from the previous version of the software. 

Press Load Settings... button and a dialog will open, where you can browse for the desired file(s). 
Once you have selected the file(s), press Update configuration files button in order to effectively 
realize the update. 
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Figure 44 - Migrate TissueFAXS configuration files dialog 

Backup of Configuration Files: if you press this button, TissueFAXS will automatically perform a 
backup for all current configuration files. You will be displayed a message box with the storage 
details, like in the image below: 

 

Figure 45 - Backup of Configuration Files message box 

 

- Use the Load settings feature ONLY if you are instructed by TissueGnostics 
personnel or authorized distributors. 

- Load settings feature is only available if logged as technician or administrator. 

- After the update is finished, the application will be automatically closed. 

 

4.5. Experiment Options 

4.5.1 Preview 

This dialog resembles very much to the Preview dialog from the default options above. The difference 
is that changes in this dialog affect the actual experiment. 
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Figure 46 - Experiment Options: Preview dialog 

4.6. Hardware Profile 

In the lower part of the Options panel you can find the Hardware Profile section. A hardware profile 
is a profile that will save most of the settings from Options form, depending on user's needs (for 
instance depending on sample's type). Please see Chapter 11. 

 

Figure 47 - Options: Hardware Profile 

In order to effectively save a profile, press Save Hardware Profile button. In the dialog that appears, 
write a name and, if you wish, a description, then press Save button. Your newly created hardware 
profile will be saved and ready for further use. 
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Figure 48 - Saving Hardware Profile 

If you wish to load a previously created hardware profile, press Load Hardware Profile button. In the 
dialog that appears, select desired profile from the dropdown list, then press Load button. The 
hardware profile will be loaded and ready to use. 

 

Figure 49 - Loading Hardware Profile 

4.7. Calibrate Field of View 

The camera calibration is a basic, but essential operation when using TissueFAXS, as the quality of 
the acquired images directly depends on it. We advise you paying maximum attention and 
perform the calibration with particular care. 

We recommend calibrating the size of the Field of View for each objective from Tools → Calibrate 
Field of View… menu. 
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Figure 50 - Field of View Calibration control panel 

 

This dialog allows you to compute the size of the Field of View for the current objective. 

In order to accomplish this task, you have three possibilities:  

- manual calibration;  

- automatic calibration; 

- distance calibration. 

 

- FOV calibration can only be performed if you are logged as Administrator. 

- For all FOV calibration methods, it is recommended to use a slide containing a more 
prominent area, in order to track it easier. 

- For optimal results, you may use a calibration slide (the calibration slide is mandatory 
for the distance calibration method). 

 

4.7.1 Manual FOV Calibration 

• Choose a reference point on the sample. For a good evaluation of the reference point, please 
make sure the whole object is in focus; 

• Move the reference point in the upper-right corner by using the software or hardware joystick; 
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Figure 51 - Reference Point: Upper-Right Corner 

 

• Press Top, then Right; 

 

Figure 52 - Manual calibration (a) 
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• Using the joystick, move the reference point from the upper-right corner to the lower-left corner; 

 

Figure 53 - Reference Point: Lower-Left Corner 

 

• Press Bottom, then Left. At this point, the Width and the Height values will automatically be 
computed; 

• To save the computed values, press Save and Exit. 
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Figure 54 - Manual calibration (b) 

 

- If you already know the FOV size, you can introduce the Width and Height values by 
yourself in their corresponding fields. 

 

4.7.2 Automatic FOV Calibration 

• Choose a reference point on the sample. For a good evaluation of the reference point, please 
make sure the whole object is in focus. 
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Figure 55 - Generic tissue sample. The point in the center is the reference object. 

 

If using a calibration slide, place the center of the calibration slide on the live image like in the figure 
below.  
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Figure 56 - Calibration slide centered 

 

 

- In order to bring up the red cross (marking the center of the calibration slide) on the 
live image, use the key combination Alt+C. 

 

 

- Do not use images with repeating patterns! (For instance, slides with fluorescence 
beads might contain many similar objects and auto calibration will fail or return wrong 
results.) 

- Ensure the speed of the stage is low! 

 

• Press Automatic Calibration button. The stage will be moved and the software will determine 
the following: 

- The correct flip settings. You will be prompted only if the current flip settings are wrong. 

 

Figure 57 - Message warning that the current flip settings on camera are wrong 
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- The angle that is formed when the camera is misaligned. You will need to manually rotate the 
camera and rerun the calibration to recheck this. 

 

 

- The angle value should be around 0.01. Values higher than 0.09 will generate bad 
quality of stitching. 

 

- The dimensions of the FOV. 

 

Figure 58 - Output of the Automatic FOV calibration 

 

 

- For best results, set the speed of the stage at a minimum value. When using other 
slides than calibration slides, you can run this procedure on different areas to ensure 
the correct value is computed. 

 

 

- If the image is flipped, the algorithm will detect this and will set the image to the right 
position. 

 

• To save the computed values, press Save and Exit. 

4.7.3 Distance Calibration 

• Insert the calibration slide in an empty insert position; 

• Choose the objective for which you want to perform the calibration;  

• Enable the live image, focus and center the calibration slide on the live image;  

• Access the calibration function: from Tools ( ) menu, choose Calibrate Field of View… 
option: 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 58 of 211 

 Internal 
 

 

Figure 59 - Tools menu 

• The Field of View Calibration control panel will appear: 

 

Figure 60 - Field of View Calibration control panel 

• Now press Distance Calibration button ( ) and the Distance Calibration 
panel will appear. 
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Figure 61 - Distance calibration panel (a) 

• Draw a line between two points for which you know the distance. Click in a desired point to start 
drawing the line, then click again to determine the end of the line. In our example, the squares on 

the calibration slides are 100µmX100µm. Use a distance as big as possible in order to improve 
results;  

• Specify the distance between the two selected points (the value must be in µm);  

• Press Compute button: FOV Width, FOV Height, Pixel size and FOV size ratio will automatically 
be computed; 

• Press OK button in order to save the obtained values. 
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Figure 62 - Distance calibration panel (b) 

 

 

About calibration methods: 

- Only the FOV values for the current objective have been calculated / recalculated this 
far. In order to compute the FOV sizes for the rest of the objectives, repeat the steps 
for each objective. For a quick setup, but less precise, you can select the objective 
with the medium magnification between your objectives, compute its FOV size and, 

before pressing Save and Exit ( ), select Automatically Compute 
calibration for other objectives. 

- At any time, you can press Cancel if you don’t want to save the changes. 
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Figure 63 - Field of View Calibration control panel: final operations  

 

4.8. Compute Objective Offsets 

Usually the objectives present on a microscope are not perfectly centered on the same point. To 
avoid situations when acquisition images are slightly moved compared to the preview image the 
objective offsets must be computed. All TissueGnostics systems have this calibration done at 
delivery time and you should not use this function unless instructed so by the support personnel.  For 
best results please use a calibration slide in the next steps. 

 Compute Objective Offsets is available from the Tools menu. 

 

Figure 64 - Compute Objective Offset Menu 
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The wizard will appear. First step is to select the reference objective. Recommended one is 20x or if 
you don’t have it an objective with a medium magnification.  Press Next after the desired objective 
has been selected.  

 

 

Figure 65 – Compute Objective Offset Wizard 

 

Figure 66 – Compute Objective Offset Wizard 
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Once this appears follow the steps: 

1. Focus the image and center the reference object 

2. Press Compute 

3. Press Next Objective 

Once you have pressed Next Objective the microscope will switch to the next objective and you must 
do the same steps. 

When no more objectives are available the Next objective button will become disable and you can 
click on Next.  The following summary will appear: 

 

Figure 67 – Compute Objective Offset Results 

If you see values larger than 200 micrometers something went wrong and you should check if the 
objectives are properly inserted after that you will need to rerun this wizard. 

If the values are smaller than 200 micrometers you should press Finish. To check if the values are 
correct you should preview a slide, (do not use existing previews) then define and acquire a small 
region. If the acquired region matches with the preview then the wizard was successful.  

 

4.9. Adjust Channel Offsets 

In fluorescence experiments you might encounter cases when the focus plane differs from reflector to 
reflector. To work around this issue use the Adjust Channel Offsets menu located in the Tools 

menu or choose Adjust Channel Offsets button ( ) from TissueFAXS main toolbar. 
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Figure 68  - Adjust Channel Offsets 

 

The first step is to select a reference reflector and to focus on it. 

 

Figure 69 - Adjust Channel Offsets Step 1 

 

After you have pressed next TissueFAXS will switch to the first reflector. Follow the on screen 
instructions. 
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Figure 70 - Adjust Channel Offsets Step 2 

 

When you have passed through all the reflectors and you press Next the following summary will 
appear.  

 

Figure 71 - Adjust Channel Offsets Summary 

You can press Finish. To test the results you can define a 1x1 region and check the images on each 
channel to see it the images are in focus.  



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 66 of 211 

 Internal 
 

5. Users 

Managing the users in TissueFAXS is really simple and intuitive. 

In order to use the application, you have to be authenticated, by owning a username and a password. 

5.1.1 View Users 

To manage the users, you must be logged in as Administrator. In TissueFAXS, there is only one 
Administrator and a set of users, who may be managed in the application when the Administrator is 
logged in. 

From the main menu, choose Admin, then Users, and a panel will appear: 

 

Figure 72 - Users dialog 

5.1.2 Adding Users 

Click on the Add user button and you will get the following panel: 
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Figure 73 - Adding Users dialog 

Here, you can fill necessary information concerning the new user, as the User Name, the Real Name, 
the Password, Description and role. 

 

- All fields, excepting Description, are mandatory. 

 

5.1.3 Modifying Users 

By pressing Modify user button, you can use the panel that appears to update the real name, the 
description and the role of the user. 

 

Figure 74 - Modify User dialog 

5.1.4 Delete Users 

To delete a user, select it in the User list dialog, then press Delete user button. You will receive a 
final warning before the effective deletion; it looks like the image below: 
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Figure 75 - Delete User message box 

5.1.5 Change Password (Administrator Mode) 

When you are logged in as Administrator, you can change other users’ passwords by using the dialog 
shown in the image below. To change the password, the application will first ask you to type the old 
password, then the new password and its confirmation. 

 

 

Figure 76 - Changing other user’s password dialog 

5.1.6 Role Based Administration 

In order to prevent certain untrained users to access the advanced controls of the application, a role 
based policy exists in TissueFAXS. 

Role based administration implies access restriction to non-administrators for advanced controls of 
the application. 

The roles can be assigned in two ways: 

• When creating a new user, choose one of the three available options from the Role dropdown box: 
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Figure 77 - New User: assigning role 

When modifying a user, choose one of the three available options from the Role dropdown box: 

 

Figure 78 - Modify User: assigning role 

The following user roles are available: 

1. User   

• This role cannot modify wide system settings like FOV calibration or scan strategies.  

2. Technician  

• This role can modify wide system settings like FOV calibration.  

• Inherits all the rights of the User role.  

3. Administrator  

• This role can modify the list of users and their roles.  

• Inherits all the rights of the Technician role.  

List of settings and the minimum access level: 

If using the Role Based Administration feature, some settings will be available only for Administrator 
or Technician. Please see table below for more details: 
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Operation Minimum 
Access Level  

Behavior for users without 
access 

Run Algorithms Technician Hidden 

Calibrate Field Of View Technician Hidden 

Test Microscope Technician Hidden 

Test Stage Precision Technician Hidden 

Administrate Users Administrator Hidden 

Options → Default Experiment Settings → 
Storage → Raw Data 

Technician Disabled 

Options → Scan Settings → Scan Strategy Technician Disabled 

Options → Scan Settings → Speed Technician Disabled 

Options → Application Options → Actions → 
Move To a Safe distance 

Technician Disabled 

Options → Application Options → Actions → 
Calibration  

Technician Disabled 

Options →  Application Options → Support → 
Connection Details 

Technician Disabled 

Options → Application Options → Support → Test 
Connection 

Technician Disabled 

Camera → Advanced Technician Hidden 

Options → Application Options → Licensing Technician Disabled 
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6. Using TissueFAXS 

6.1. New Experiment  

 

In order to acquire images in TissueFAXS, it is essential to create a new experiment or open an 
existing one.  All images, settings and data are saved and embedded in your experiment files and 
folder. 

The only thing you can do if you don’t have a current experiment opened is to preview slides or 
acquire single images from the camera window. 

6.1.1 Opening an existing experiment 

To browse for an existing experiment press Open button ( ) from the toolbar or press Open… 

from the File menu ( ). 

To access the recently used experiments press Open button arrow ( ) from the toolbar or 

press Open… arrow from the File menu ( ): 

 

Figure 79 - Recent Experiments list 

From this list, choose the desired experiment and left click on its name to open it. 

Currently opened experiment name appears bold on the list. 

If you choose View for All Users option, Recent Experiments dialog will open. Here you can see the 
previously opened experiments by other users (see Chapter 5.1.6) and you can open any experiment 
by double clicking on it. 

You can delete items from the Recent Experiments dialog by selecting desired item(s) ad pressing 
Delete button from your keyboard. You can also use the contextual menu that appears when right-
clicking on any item in the list. 

 
 

Figure 80 - Recent Experiments: contextual menu 
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Figure 81 - Recent Experiments dialog 

6.1.2 Experiment Creation 

It’s easy to create a new experiment, as TissueFAXS offers a user-friendly New Experiment panel.  

To begin creating a new experiment, follow the steps below: 

• Go to File → New… menu: 

 

Figure 82 - New Experiment menu 

• Or go directly in the toolbar: 
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Figure 83 - New Experiment (toolbar) 

At this point, the New Experiment panel will open: 

                      

Figure 84 - Experiment Creation  

Now you have the following options: 

• Create a new experiment based on an existing template /an existing experiment 

 

- Usually, templates are defined by system technicians or by support staff. On the other 
hand, an existing experiment can be used to create a new one when you want to keep 
exactly the same settings from an experiment to another. 

 

• Create a new custom brightfield experiment 

• Create a new custom fluorescence experiment 

 

 

 

Create a new experiment based on an existing template/an existing experiment 
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From the list of templates on the left side of the New Experiment panel, choose desired item. The 
following panel will open: 

  

Figure 85 - New Experiment panel: create new experiment from template (a) 

 

You can customize some of the fields that will appear on the right side of the New Experiment panel 
and modify the data if desired: 

• Experiment name:  the corresponding TissueFAXS experiment file will have this name and it 
will be stored in a folder having by default the same name as the experiment (it can be modified 
later). 

• Storage folder: to change the experiment storage folder just click on the label and then 
browse for the desired folder. 

 

- Please ensure that you have enough rights on the selected folder. 

- Please ensure that you have enough free space on the drive where the folder is 
located. The free space required depends on the file image format but at least 10 GB 
is recommended. 

 

• Comment (optional): you can add a short description of the experiment. 

 

- By default, the following sections are collapsed: Preview and Acquisition Settings, 
Slides, Template/Existing Experiment Path. You can expand them if you like; in this 
case the New Experiment form will look like in the picture below: 
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Figure 86 - New Experiment panel: create new experiment from template (b) 

 

• In the Slides section, you can edit slide's name, set the content type (generic or TMA) or add 
a comment. 

• You can find out details about the template by pressing Details button ( ) 

 
Figure 87 - Details window 

 
• Import defined regions (available for creating a new experiment from an existing one): check this 

case to import the regions from the old experiment to the new one. 

 

Figure 88 - Import defined regions button 
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• Select desired hardware profile (for details please see Chapter 4.6): use current settings or use 
the settings from the template 

 
Figure 89 - Hardware profile options 

 

• Choose whether you want to acquire your slides or if you just want to create the new experiment. 
If you choose to acquire, you must decide if your acquisition will also imply manual correction. If 
you choose Acquire with Manual Correction, TissueFAXS will allow you to manually intervene 
to enhance the quality of detection for each sample. 

 

Figure 90 - Acquire options 

 

Create a new custom brightfield experiment 

From the left side of the New Experiment panel, choose Custom BF. The following panel will open: 

 

Figure 91 - New Experiment panel: create new custom brightfield experiment 
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You can customize some of the fields that will appear on the right side of the New Experiment panel 
and modify the data if desired: 

• Experiment name 

• Storage folder 

• Comment (optional) 

• Preview and acquisition settings: objectives, camera, camera profile (if any) 

 

- In brightfield experiments no selection can be made for reflectors. The channel 
Transmission is selected by default (it is specific for the Brightfield Experiments) 

 

Preview Settings 

Settings for the preview operations can be set by clicking on the Preview Settings button 

( ). You can choose a preview schema from the list and select the position of the 
label from the slide (up or down).  This slide label setting will remain the same for the entire 
experiment.  It can only be changed later for single slides. 

In addition, you can also select a profile with predefined settings from the dialog. 

All settings made here can be changed later if necessary, only the experiment type cannot be 
changed. 

You can adjust the preview area size by clicking on the  button. The preview area (or 
yellow box) can be manually adjusted with the mouse or you may select a pre-defined schema from 
the drop-down menu.  

  

Figure 92 - Preview Area Settings panel 

You can give a name to your Preview Schema and save it for future projects. This is useful when you 
have multiple slides which frequently have the region of interest (tissue) in the same specific location. 
Defining your preview schema over your region of interest will save time; otherwise the microscope 
will scan the entire slide in order to preview it. 

The Hint area displays the preview schema size in terms of number of fields of view (FOVs). 
Additionally, the type of camera and objective used for preview is shown. 
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In the Label Position area, you can specify how your slide is oriented on the stage. This is not a 
definitive setting. For instance, even if your slides have the labels oriented down, you can change this 
later in the project for individual slides or for multiple slides. To do this later, just right click on the 
slide(s) and change its label position. 

 

• In the Slides section, you can edit slide's name, set the content type (generic or TMA) or add 
a comment. 

• You can find out details about the template by pressing Details button ( ) 

 

• Select desired hardware profile (for details please see Chapter 4.6): use current settings or use 
the settings from the template 

 
Figure 93 - Hardware profile options 

 

• Choose whether you want to acquire your slides or if you just want to create the new experiment. 
If you choose to acquire, you must decide if your acquisition will also imply manual correction. 

 

Figure 94 - Acquire options 

 

 

Create a new custom fluorescence experiment 

From the left side of the New Experiment panel, choose Custom FL. The following panel will open: 
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Figure 95 - New Experiment panel: create new custom fluorescence experiment 

You can customize some of the fields that will appear on the right side of the New Experiment panel 
and modify the data if desired: 

• Experiment name 

• Storage folder 

• Comment (optional) 

• Preview and acquisition settings: objectives, reflectors, camera, camera profile (if any) 

Preview Settings 

Settings for the preview operations can be set by clicking on the Preview Settings button 

( ). You can choose a preview schema from the list and select the position of the 
label from the slide (up or down).  This slide label setting will remain the same for the entire 
experiment.  It can only be changed later for single slides. 

In addition, you can also select a profile with predefined settings from the dialog. 

All settings made here can be changed later if necessary, only the experiment type cannot be 
changed. 

You can adjust the preview area size by clicking on the  button. The preview area (or 
yellow box) can be manually adjusted with the mouse or you may select a pre-defined schema from 
the drop-down menu.  
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Figure 96 - Preview Area Settings panel 

You can give a name to your Preview Schema and save it for future projects. This is useful when you 
have multiple slides which frequently have the region of interest (tissue) in the same specific location. 
Defining your preview schema over your region of interest will save time; otherwise the microscope 
will scan the entire slide in order to preview it. 

The Hint area displays the preview schema size in terms of number of fields of view (FOVs). 
Additionally, the type of camera and objective used for preview is shown. 

In the Label Position area, you can specify how your slide is oriented on the stage. This is not a 
definitive setting. For instance, even if your slides have the labels oriented down, you can change this 
later in the project for individual slides or for multiple slides. To do this later, just right click on the 
slide(s) and change its label position. 

 

• In the Slides section, you can edit slide's name, set the content type (generic or TMA) or add 
a comment. 

• You can find out details about the template by pressing Details button ( ) 

 

 
• Select desired hardware profile (for details please see Chapter 4.6): use current settings or use 

the settings from the template. 

 
Figure 97 - Hardware profile options 

 

• Choose whether you want to acquire your slides or if you just want to create the new experiment. 
If you choose to acquire, you must decide if your acquisition will also imply manual correction. 
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Figure 98 - Acquire options 

6.2. Preview Settings 

Preview Settings can be accessed by clicking on the Preview tab in the upper left corner of the main 
TissueFAXS window. If the Preview tab is not visible, you can make it visible by pressing the 
Settings button from the application’s toolbar. 

 

Figure 99 - Preview tab 

This feature of TissueFAXS covers the settings for the preview operation, such as the objective 
(which must be a low magnification objective), channels (for instance the reflectors in use) and 
individual settings for each channel. 

In the next two sections, the workflow for brightfield and fluorescence experiments will be 
described. 

6.2.1 Brightfield Experiment 

For a Brightfield Experiment you can select the objective used for preview. 

To edit the camera settings for a channel, click the View button ( ). For further details 
see Chapter 6.6. from the current manual. 

 

 

- You cannot add or remove channels. The default channel is Transmission and cannot 
be changed.  If you don’t have a Transmission channel (e.g. a missing reflector in the 
reflector changer) you will not be able to acquire brightfield images. 

- To adjust the camera settings for the channel Transmission, you must have a camera 

present in your project. Otherwise, the View button ( ) for each 
channel will not be visible. 

 

 

- If you had made previews without any experiment and then created a new experiment, 
the previews will be lost. 
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Figure 100 - Preview settings panel 

 

6.2.2 Fluorescence Experiment 

For a Fluorescence Experiment, you can select the objective used for preview, the channels used 
for preview and the camera settings for each channel. 

To add or remove channels, press the Add/Remove Channels… button ( ). 
In the dropdown list that appears, the already selected channels will appear checked. 

 

Figure 101 - Preview Settings panel: Channel list 

 

Figure 102 - Preview Settings panel: Channels inserted 

 

To edit the camera settings for a channel, click the View button next to it. For further details see 
Chapter 6.6. of the current manual. 

You can change the names of the channels by clicking on each in the settings field. 

 

- To adjust the camera settings for any channel, you must have a camera present in 

your project. Otherwise, the View button ( ) for each channel will not 
be visible. 
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You can select more than one channel for the preview operation because each slide can be scanned 
multiple times (once for each channel in the list, that will yield the final overlay image).  For each 
channel you may adjust the camera settings (light intensity, exposure time, colors, etc) by pressing 
the View button next to each reflector in the list. Make your adjustments in the new window that 
appears and press Save. When all your channel settings are saved, you are ready to acquire your 
preview image. 

It might be an option to make the preview for fluorescent experiments in darkfield illumination. 

6.3. Acquisition  

If the user simply presses the Acquire button from TissueFAXS main toolbar, the application will 
perform the Finish Acquisition action.  

All the acquisition options can be found by pressing the arrow of the Acquire button ( ).  

A dropdown menu like in the image below will appear: 

 

Figure 103 - Acquisition Options 

The following options are available: 

• Finish Acquisition: TissueFAXS will acquire only the unacquired FOVs from the experiment; 
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Figure 104 - Finish acquisition 

• Acquire All...: TissueFAXS will acquire all the FOVs of the experiment and will also erase all already acquired 
FOVs; 

 

Figure 105 - Acquire All 

• Select Items to Acquire...: the user will select the items to be acquired (slides, ROIs). 
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Figure 106 - Select Items to acquire 

 

• Preview and Acquire: the user must select the slides for automatic preview and acquisition. Also, the tissue 
detection for selected items can be enabled by checking Verify Tissue Detection. 

 

Figure 107 - Preview and Acquire 

6.3.1 Acquisition Settings 

Acquisition settings can be accessed by clicking on the Acquisition tab in the upper left corner of the 
main TissueFAXS window. If the Acquisition tab is not visible, you can make it visible by pressing 
the Settings button from the application’s toolbar. 

 

Figure 108 - Acquisition tab 

 

- Acquisition settings are similar to the preview settings, except for the fact that they act 
when acquiring regions.  
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- The list of objectives which may be used for acquisition is not limited (as for the 
preview). 

- An important difference is that you can select the channel for auto focus in the 
acquisition workflow.  

 

 

Figure 109 - Acquisition Settings panel 

 

Focus Channel 

The Focus Channel is the channel for which TissueFAXS will perform the auto focus in fluorescence 
experiments. The focus for Focus Channel will be memorized by the application and then used in 
acquiring the other channels. 

The default Focus Channel in TissueFAXS fluorescence experiments is DAPI. If DAPI is absent 
from the experiment, TissueFAXS will automatically set as Focus Channel  the first channel listed in 
the Acquisition Channel section. 

Channels 

• For Brightfield Experiment: Only Transmission is available; 

• For Fluorescence Experiment: choose the desired reflector (including transmission). 

 

- After choosing the reflectors, you must readjust the camera settings for each reflector. 

- The name of the channel is editable. 

 

Objective Lens 

Select the desired objective from Acquisition → Acquisition Objective. 

 

- After choosing the acquisition objective, you must readjust the camera settings for 
each combination of acquisition objective and acquisition channel. 

 

Camera Settings 

To edit camera settings press View button. For more information please see Chapter 6.6. of the 
current manual. 

You may also want to use settings from camera profiles (if you have previously created any) instead 
of making new settings for the camera. For more information about camera profiles please see 
Chapter 6.8. 

Additionally, TissueFAXS stores TL lamp intensity value (for Transmission) and attenuator settings 
value (for Fluorescence channels) per channel. 
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Figure 110 - Camera Settings 

Experiment Profile 

An Experiment Profile represents a set of settings (camera, acquisition objective, preview channels, 
acquisition channels) that you can save for further use, in order to make available different 
combinations of settings for the preview and acquisition. To access Experiment Profile options, go to 
acquisition settings tab and press Experiment Profile button… 

 

Figure 111 - Profile Options menu 

 

• Save: the current preview and acquisition settings can be saved in order to make them 
available for other experiments. Please specify a name and a short description for this profile. 
A default name is already generated. It contains the camera name and type, the objective 
magnification and the reflectors selected for acquisition; you can also add your own information 
to the name. 
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Figure 112 - Save Profile dialog 

 

• Load: an existing profile can be loaded for current experiment. You must select any profile you 
want from the existing list. 
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Figure 113 - Load Profile dialog 

• Delete: if an existing profile is no longer needed, it can be deleted by selecting it and then 
pressing the Delete button. 
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Figure 114 - Delete Profile dialog 

6.3.2 Standard acquisition vs Time Lapse acquisition 

Time lapse acquisition consists of multiple acquisitions for a region or a set of regions. The multiple 
acquisitions will be performed after a certain time interval specified by the user. 

Time lapse feature is ideal for observing cell cultures. 

How to acquire 

A region can be acquired in two modes: Standard (normal) or Time Lapse. 

You can specify the acquisition type in the Acquisition Information dialog that is displayed before 
the actual acquisition process is started. 
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Figure 115 - Acquisition Information: Standard (left image) and Time Lapse (right image) 

 

To enable Standard acquisition mode, the Time Lapse acquisition checkbox must not be ticked. 
To enable Time Lapse Acquisition, then Time Lapse acquisition checkbox must be ticked and the 
user should also set the values for the following parameters: 

• Number of runs: how many times the acquisition will run; 

• Time lapse: the interval between runs. The time lapse will be specified like this: days. hours: 
minutes: seconds. 

For every region acquired with short time lapse, this information will be displayed in the Region 
properties section from the Experiment Editor (see Chapter 6.13). 

 

Figure 116 - Experiment editor: region acquired with short time lapse 

 

- If you frequently use Time Lapse acquisition, you can set this option as default from 
Tools → Options → Application Options → Remember (along with the desired 
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parameters values).  

 

 

Figure 117 - Remember dialog: Time lapse acquisition section  

Acquisition e-Mail Report 

Within the Acquisition Information panel, press  button in order to access the Acquisition 
e-Mail Report dialog. Please check Send e-Mail after Acquisition Finishes checkbox, then fill in the 
desired e-Mail address and press OK. TissueFAXS will remember this information for further use. As 
soon as the acquisition process will end, you will be notified by e-mail.  

 

Figure 118 - Acquisition Information: Acquisition e-Mail Report 
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How to view 

By default, when double clicking on a region in Experiment Editor, that region will open in Time 
Lapse mode (if time lapse images have been acquired) or in Standard Mode (if time lapse images 
have not been acquired).  

Be aware that not all operations normally available on a region are available on a set of Time Lapse 
images (see also Chapter 6.16):  

• Adding/Removing FOVs option is not available; 

• Reacquisition of specified FOVs is not available; 

• Resize of the region is not available; 

• There is only one correction image for all Time Lapse images belonging to the same region; 

• All the categories/subregions will be the same for all Time Lapse images belonging to the same 
region.  

 

Figure 119 - Region viewer toolbar: Time Lapse mode 

Assuming a region has both Standard and Time Lapse images, the user can switch between these 

two modes by using two buttons:    ↔  .  

The user can choose to see the region at a certain moment by moving the cursor 

( ) or by pressing  and  buttons. 

The user can delete all time lapse images by pressing the Remove button ( ). 

 

- Time Lapse acquisition is not available for TMA samples (see Chapter 7). 

- During the Time lapse acquisition process, the user can see the progress of the 
acquisition in the status bar of the application. 

 

 

Figure 120 - Example of Status Bar 
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6.4. Microscope 

In this section of the manual, you will find a description of those components of the microscope that 
can be controlled by using TissueFAXS and you will learn how to use them. 

 

6.4.1 Objectives 

 

Figure 121 - Objective Turret control 
(a) 

The Objectives panel displays the objectives available in the microscope’s 
Objective Turret. 
 

 The first listed missing objective is displayed as 0x. The rest of the 
missing objectives are not displayed. 

 

Figure 122 - Objective Turret control 
(b) 

Select an objective from this panel by clicking on it. This will switch the 
current objective to the selected one.  
 

The objective in use is always shown in red. 

6.4.2 Reflectors 

 

Figure 123 - Reflector Turret control (a) 

The Reflectors panel displays all the reflectors available in the 
microscope’s Reflector Turret. 
 

 The first listed empty position in the reflector turret is 
displayed as Transmission. The rest of the missing reflectors are 
not displayed. 

 

Figure 124 - Reflector Turret control (b) 

Select a reflector from this panel by clicking on it. This will switch 
the current reflector to the selected one.  
 

 The current reflector in use is always surrounded by a 
black rectangle. 

 

Edit Reflectors 

A good management of your reflectors will provide good quality acquired images and will also help 
you later in your image analysis.  

Right clicking on a selected reflector will show a menu with two options: 
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Figure 125 - Context menu for selected reflector 

                                                                          

• Edit Name - the user can change the Full Name, the Short Name and the Abbreviation (max. 
4 characters) for the selected reflector. Also, the user can write a short description for this 
reflector. 

 

Figure 126 - Edit details for selected reflector 

 

 

- The user also has the possibility to choose the displayed names for the reflectors in 
the application by going to Tools → Options… → Reflectors. 

 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 96 of 211 

 Internal 
 

 

Figure 127 - Reflector Settings dialog 

 

• Edit Color - the user can set the color for the selected reflector. 

 

Figure 128 - Edit Reflector Color context menu 
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- When the mouse is over a reflector, an information dialog is automatically displayed. It 
contains brief information as abbreviation, full name and description. 

 

 

Figure 129 - Reflector Info bubble 

6.4.3 TL Shutter for transmitted light 

TL Shutter is used to block or unblock the light coming from the halogen or white-light LED lamp.  

 

 

Figure 130 - TL Shutter control (a) 

The TL Shutter is closed.  
 
Click on the shutter icon to open the TL shutter. 

 

Figure 131 - TL Shutter control (b) 

The TL Shutter is opened. 
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6.4.4 TL Lamp 

 

Figure 132 - TL Halogen Lamp control 

Use the light switch icon to turn on/off the TL Lamp. 
Right to the switch, the current state of the TL Lamp is 
displayed (On/Off). 
 
Check the 3200K check box to turn on the color 
temperature of the TL Lamp directly to 3200K. 

 The color temperature can only be set for 
halogen lamps. This checkbox has no relevance for 
white-light LED. 
 
Adjust the light intensity by moving the slider. 

 

 

- There is a small delay between changing a value on the control and the actual 
response of the lamp. For instance, when the lamp is turned on, it takes some time 
until it reaches the luminosity corresponding to the control value. 

 

6.4.5 RL Shutter for reflected light 

RL Shutter is used to block or unblock the light coming from RL lamp. This way, the light maintains 
the same intensity compared to on/off cycle and the lifetime of the lamp is increased. 

 

Figure 133 - RL Shutter control (a) 

RL Shutter is closed.  
 
Click the RL shutter icon to open the RL shutter. 

 

Figure 134 - RL Shutter control (b) 

RL Shutter is opened. 

 

6.4.6 Fluo Arc (optional component) 

A Fluo arc is a device used to dim the fluorescent lamp. It should be run at 100 % or it will flicker and 
give bad results. 
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Figure 135 - Fluo Arc control 

Fluo Arc control when present.  
 

 

 

6.4.7 White Light Attenuator (optional component) 

 

Figure 136 - White Light Attenuator control 

 
Adjusts the transmission light intensity using some 
filters.  

 

6.4.8 Fluorescence Attenuator (optional component) 

 

Figure 137 - Fluorescence Attenuator control 

Adjusts the reflected light intensity using some filters. 

 

6.4.9 Condenser 

 

Figure 138 - Condenser combo box 

The Condenser combo box allows you to select the 
desired contrast method. 
 

 In fluorescence, it is recommended to move 
the front lens out of the lightpath of the condenser. 

 Phase Contrast (PH) and Differential 
Interference Contrast (DIC) are optional components. 
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6.4.10 Condenser Front Lens 

 

Figure 139 - Condenser Front Lens 

 

 
Using the control, you can swing in or swing out the 
condenser front lens. 
For objective lenses with magnification factors smaller 
than or equal to 10x and during fluorescence 
acquisition, the front lens must always be swung out. 
Only for objective lens magnification factors higher than 
10x in transmitted light, the front lens is needed for 
concentrating the light onto the field of view. 
 

6.4.11 Condenser Aperture 

 

Figure 140 - Condenser Aperture control 

 

 
Using the slider, you can open or close the aperture 
diaphragm. 
 

 The condenser aperture determines the 
contrast in the image. Wrong contrast settings might 
impose autofocus functionality and the quality of image 
analysis. As a good start point, the condenser aperture 
should be close to the numerical aperture of the 
objective lens in use. The Light Manager will store 
individual settings for each objective lens installed. 
 

 

6.4.12 Sideport Changer 

 

Figure 141 - Sideport Changer combo box 

Sideport Changer control when present. 
 
It is used to specify to which port (observation, rear port 
and front port) the light is directed. Thus, the user can 
switch between visual observation through the oculars 
and the digital live image through a camera. 

 

6.5. Stage 

Stage Components 

The stage is the hardware component of the microscope that allows viewing different inserts and their 
contents (tissue, cell cultures, etc), by moving on the X/Y axes. TissueFAXS provides a virtual image 
of the stage with its existing inserts. 
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Figure 142 - Stage Control 

 

 

Figure 143 - Slide selected by the user 

The currently selected slide can be recognized by a 
surrounding red frame. 

 

Figure 144 - Active Slide on the microscope 

 

The slide currently placed under the objective lens can 
be recognized by a surrounding green frame. 
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- For more information, please see Chapter 6.14 of the current manual. 

 

6.6. Cameras 

TissueFAXS supports the following cameras: 

• PixeLINK cameras: select this type of camera for Brightfield imaging; 

• PCO PixelFly cameras: select this type of camera for Fluorescent imaging; 

• Hamamatsu Orca Flash 4: select this type of camera for Fluorescent imaging; 

• Baumer TXG/HXG Cameras: select this type of camera for Brightfield imaging. 

6.6.1 Adding Cameras 

To add a supported camera, follow the steps mentioned below: 

• From the Tools menu select Options… to open the Options dialog box. 

• In the Options dialog choose Hardware Settings → Camera Manager. 

 

Figure 145 - Camera Manager dialog 
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• Press Add new camera… button. The System Cameras dialog box will appear and it will 
display the cameras that are supported by TissueFAXS and are connected to your computer.  

 

 

Figure 146 - System Cameras dialog 

 
 

• In the System Cameras dialog select the desired camera and press OK. If your camera is not 
listed there, you can press Reload to rescan for connected cameras.  

 

- If your camera is already used in TissueFAXS, it is possible not to be listed, even if 
you press Reload. 

 

• Now, you will be able to see the selected camera in the combo box. 

• Frames to wait: This value indicates how many images the camera will skip before the image 
will be taken and stored. If this value is too low, the images may appear stretched, because they 
were taken before the stage has completely stopped after rapid movement (motion blur). Default 
values are 1 or 2; higher values may be suitable if you are working with cell culture dishes. 
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• Camera adapter magnification: this is an adapter used to connect the camera to the 
microscope, having its own magnification factor (written on it); if this information is missing or is 
wrong in TissueFAXS, the total magnification of the experiment will be wrong; 

• Press Save & Exit to save the settings and close the Options dialog. 

6.6.2 Change Default Camera 

You can change the camera you are using any time you need. To perform this operation follow the 
steps described below: 

• From the Tools menu select Options… to open the Options dialog box; 

• In the Options dialog choose Hardware Settings → Camera Manager; 

• Select the desired camera from the combo box. If the camera is not listed there, please see the 
steps described in Chapter 6.6.1. 

• Press Save & Exit to save the settings and close the Options dialog. 

6.6.3 Operations with Current Camera 

The camera you are currently using allows you the following actions: 

• Enable or disable the live image for the current camera (depending on what you are working at, 
you may want to see the live image or not); 

• Capture an image with the current camera (the main purpose when using the camera); 

• Adjust the settings for the current camera (in order to obtain the desired results – in preview or 
image acquisition – you are able to constantly adjust your camera settings). 

6.6.4 Remove Camera 

You can remove the camera you are using any time you need. To perform this operation follow the 
steps described below: 

• From the Tools menu select Options… to open the Options dialog box; 

• In the Options dialog choose Hardware Settings → Camera Manager; 

• Select the camera you want to remove from the combo box and press Remove camera button.  
 

 

- If the camera is not present in the combo box, its removal is no more necessary. 

 

6.6.5 Settings for PCO/PixelFly Camera 

The settings available for all cameras are divided in two categories: basic settings and advanced 
settings. Basic settings are the most frequently used, while advanced settings are rarely used, usually 
when the system is installed or in special conditions (as described in sections below).  

 

- Changes in the Advanced Settings menu should only be done by informed users, 
understanding the relevance of these controls. Changing these parameters in an 
unqualified way may cause TissueFAXS to malfunction. 
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Basic Settings 

Exposure Time: controls the amount of time available to the sensor for collecting light to form an 
image. In Async Shutter Mode (low brightness) the exposure time range is 0.01…65 ms. In Video 
Mode (high brightness) the exposure time range is 1…10000 ms. Increase this parameter when the 
illumination condition are poor or when the markers on the samples are dim (in fluorescence 
experiments). 

 

 

- Due to the large value (10000) allowed for exposure time, this control starts with the 
maximum value of 500 in order to increase usability. If you require higher exposure 
time, do a right click on this control and access the Maximum menu. 

 

 

Figure 147 - Exposure Time control 

 

Figure 148 - Changing the maximum exposure time allowed combo box 

 
 

Gain:  Controls the intensity of the image by artificially increasing the values of pixels by using 
software multiplication. Use this when you don’t want to increase the exposure time, in order to 
increase the acquisition speed. 

 

Figure 149 - Gain control 

Lower / Upper:  These parameters specify the interval which will be scaled to 256 gray levels for 
display.  

- Lower Sensitivity Threshold: by increasing this, the low intensities (like background) in the 
image will be lost. 

- Upper Sensitivity Threshold: by decreasing this value, the shades in the image will 
become brighter. 

 

 

- If you want to manually adjust these parameters, you should set them in such a way 
that the lower parameter limit equals the smallest value for which the “High 
background” is green and the highest value for the upper parameter for which the 
“Saturation” indicator is green. 
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Figure 150 - Lower / Upper parameters controls 

You can automatically adjust these parameters by pressing the Auto button. 

By choosing Advanced Options… the following dialog will appear:  

 

Figure 151 - Options for detect Lower / Upper Limit Parameters control panel 

The advanced options control how TissueFAXS detects the presence of oversaturation and 
undersaturation (lack of signal) in the camera image. 

UnderSaturation Percent: If the number of pixels with intensity value higher than the (under-) 
saturation limit is over this percent of the total number of pixel then the image is considered 
undersaturated. 

Saturation Percent: If the number of pixels with intensity value higher than the (over-) saturation limit 
is over this percent of the total number of pixel then the image is considered oversaturated. 

UnderSaturation Value: The maximum acceptable intensity value for witch a pixel is considered 
undersaturated. 

Saturation Value: The minimum acceptable intensity value for which a pixel is considered 
oversaturated. 
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Advanced Settings 

In order to access the advanced mode, right click in the area where the camera parameters are. The 

following menu will appear: . The Advanced tab will appear if checked.  

 

Pixel Addressing: this parameter is used in order to decrease the size of the captured image and 
decrease the time needed for the capture operation. This will increase overall acquisition speed, but 
the image quality will be affected (reduced). 

 

Figure 152 - Pixel Addressing combo box 

Flip: this parameter is used to flip the captured image. You can use this parameter to correct the 
orientation of the image, if the left/right or top/down of the camera are different that those of the stage. 
This parameter is generally adjusted when the system is installed. The FOV calibration feature is able 
to automatically set this parameter to its correct value. Do not change this setting unless you 
encounter failure in stitching the overview images. 

 

Figure 153 - Flip for the Image checkbox 

 

Camera Mode: You can choose Async Shutter or Video Mode. 

- The Async Shutter is recommended when there is a high amount of light reaching the 
camera sensor (like in Brightfield). The stepsize of the exposure time can be adjusted in 
1/10 of a second to a maximum exposure time of 50 ms.  

- The Video Mode is recommended when there is a low amount of light reaching the camera 
sensor. This mode is recommended for Fluorescence experiments. The stepsize of the 
exposure time can be adjusted in 1-second steps to a maximum exposure time of 10,000 ms 
(10 sec). 

 

Figure 154 - Camera Mode radio buttons 

 

Display Information on Camera ( ): when enabled, this option will display 
on the live image the histogram, the saturation and the high background indicators. 

Display Scale bar ( ): when enabled, this option will display the scale bar on the live 
image. 
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Display Gray value ( ): when enabled, this option will display the gray value of a 
pixel selected with the mouse. 

 

 

Figure 155 - Information Displayed on Camera 

 

 

- If areas appear labeled in red within a fluorescence image, this means those areas are 
(over-)saturated. 

 

6.6.6 Settings for PCO USB Camera 

The settings available for all cameras are divided in two categories: basic settings and advanced 
settings. Basic settings are the most frequently used, while advanced settings are rarely used, usually 
when the system is installed or in special conditions (as described in sections below).  

 

- Changes in the Advanced Settings menu should only be done by informed users, 
understanding the relevance of these controls. Changing these parameters in an 
unqualified way may cause TissueFAXS to malfunction. 

 

Basic Settings 
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Exposure Time: controls the amount of time available to the sensor for collecting light to form an 
image. In Async Shutter Mode (low brightness) the exposure time range is 0.01…65 ms. In Video 
Mode (high brightness) the exposure time range is 1…10000 ms. Increase this parameter when the 
illumination condition are poor or when the markers on the samples are dim (in fluorescence 
experiments). 

 

 

- Due to the large value (10000) allowed for exposure time, this control starts with the 
maximum value of 500 in order to increase usability. If you require higher exposure 
time, do a right click on this control and access the Maximum menu. 

 

 

Figure 156 - Exposure Time control 

 

Figure 157 - Changing the maximum exposure time allowed combo box 

 
 

Lower / Upper:  These parameters specify the interval which will be scaled to 256 gray levels for 
display.  

- Lower Sensitivity Threshold: by increasing this, the low intensities (like background) in the 
image will be lost. 

- Upper Sensitivity Threshold: by decreasing this value, the shades in the image will 
become brighter. 

 

 

- If you want to manually adjust these parameters, you should set them in such a way 
that the lower parameter limit equals the smallest value for which the “High 
background” is green and the highest value for the upper parameter for which the 
“Saturation” indicator is green. 
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Figure 158 - Lower / Upper parameters controls 

You can automatically adjust these parameters by pressing the Auto button. 

By choosing Advanced Options… the following dialog will appear:  

 

Figure 159 - Options for detect Lower / Upper Limit Parameters control panel 

The advanced options control how TissueFAXS detects the presence of oversaturation and 
undersaturation (lack of signal) in the camera image. 

UnderSaturation Percent: If the number of pixels with intensity value higher than the (under-) 
saturation limit is over this percent of the total number of pixel then the image is considered 
undersaturated. 

Saturation Percent: If the number of pixels with intensity value higher than the (over-) saturation limit 
is over this percent of the total number of pixel then the image is considered oversaturated. 

UnderSaturation Value: The maximum acceptable intensity value for witch a pixel is considered 
undersaturated. 

Saturation Value: The minimum acceptable intensity value for which a pixel is considered 
oversaturated. 
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Advanced Settings 

In order to access the advanced mode, right click in the area where the camera parameters are. The 

following menu will appear: . The Advanced tab will appear if checked.  

 

Pixel Addressing: this parameter is used in order to decrease the size of the captured image and 
decrease the time needed for the capture operation. This will increase overall acquisition speed, but 
the image quality will be affected (reduced). 

 

Figure 160 - Pixel Addressing combo box 

Flip: this parameter is used to flip the captured image. You can use this parameter to correct the 
orientation of the image, if the left/right or top/down of the camera are different that those of the stage. 
This parameter is generally adjusted when the system is installed. The FOV calibration feature is able 
to automatically set this parameter to its correct value. Please do not change this setting unless you 
encounter failure in stitching the overview images. 

 

Figure 161 - Flip for the Image checkbox 

 

6.6.7 Settings for PixeLINK Camera 

The settings available for all cameras are divided in two categories: basic settings and advanced 
settings. Basing settings are the most frequently used, while advanced settings are rarely used and 
should only be changed by experienced users. Usually, advanced settings are only needed when the 
system is installed or in special conditions (as described in sections below). 

 

Basic Settings 

Exposure Time: The amount of time available to the sensor for collecting light to form an image. 

Increase this parameter when the light intensity is low.  
 

 

Figure 162 - Exposure Time control 

 

White Balance: this parameter adjusts the intensity of the Red, Green and Blue colors in order to 
render a neutral color correctly (white is usually used as a reference). You can press Auto to 
autobalance the colors. When the transmitted light is not white, you can use this parameter in order to 
correct the hue of the light in order to obtain the reference white light. 
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Figure 163 - White Balance control 

 

Saturation: represents the purity or strength of a color, due to absence of black, white or gray. 
Adjusting color saturation will affect how intense the tones of the color are in your image. Use this in 
order to enhance colors on tissues with faded colors.  

The default value for Saturation is 150. If the user wants to set the default value for this parameter he 
must press the Default button.  

  

Figure 164 - Saturation control 

 

Display Information on Camera ( ): when enabled, this option will display 
on the live image the histogram, the saturation and the high background indicators. 

Display Scale bar ( ): when enabled, this option will display the scale bar on the live 
image. 

Display RGB value ( ): when enabled, this option will display the RGB value on the 
live image. 

 

Advanced Settings 

In order to access the advanced mode, right click in the area where the camera parameters are. The 

following menu will appear: . The Advanced tab will appear when checked.  

 
 

Frame rate: the maximum number of images captured per second. 

 

Figure 165 - Frame Rate control 

 

Pixel Addressing: this parameter is used in order to decrease the size of the captured image and 
decrease the time needed for the capture operation. This will increase overall acquisition speed, but 
the image quality will be affected (reduced). 
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Figure 166 - Pixel Addressing combo box 

 

Color Temperature: this parameter is similar to white balance making the picture look colder or 
warmer. 

 

Figure 167 - Color Temperature control 

 

Pixel Format: the format used when transferring images from the camera (only experts in imaging 
should change the settings). 

 

Figure 168 - Pixel Format combo box 

 

Resolution: this is the size (in pixels) of the captured images. 

 

Figure 169 - Resolution combo box 

 

Flip: this parameter is used to flip the captured image. You can use this parameter to correct the 
orientation of the image, if the left/right or top/down of the camera are different that those of the stage. 
This parameter is generally adjusted when the system is installed. The FOV calibration feature is able 
to automatically set this parameter to its correct value. 

 

Figure 170 - Flip Image control 

 

Rotate Image: this parameter is used to rotate the captured image. Use this when the camera is 
placed in a 90/180/270 degrees position in relation to the stage. 

 

Figure 171 - Rotate Image radio buttons 
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Gain: artificially adjusts the intensity of pixels (by software multiplication of pixel values). 

 

Figure 172 - Gain control 

Sensor saturation: This set of parameters has no effect on the final images. This sensor is used only 
to warn the user of possibly over saturated pictures that can later affect the illumination correction 
process. The two parameters are:  

- Max allowed values: if you have a very bright image that is considered oversaturated (the 
sensor turns red), you can increase this value in order to make the sensor accept it.  

- Sensor saturation area: if the number of bright pixels (with a value above maximum 
allowed) is lower than Sensor saturation area, the image is considered to be fine; otherwise, 
it is considered oversaturated. Generally, you might want to increase this value when 
working with samples having many bright areas. 

 

Figure 173 - Sensor saturation 

Gamma: adjusts the contrast of the image. You can use this to highlight the differences between the 
light and dark areas or in order to minimize these differences. 

 

Figure 174 - Gamma control 

6.6.8 Settings for Hamamatsu ORCA FLASH 4.0 Cameras (USB and CAMLINK 
connection) 

The settings available for the camera are divided in two categories: basic settings and advanced 
settings. Basing settings are the most frequently used, while advanced settings are rarely used and 
should only be changed by experienced users. Usually, advanced settings are only needed when the 
system is installed or in special conditions (as described in sections below). 
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Basic Settings 

Exposure Time: The amount of time available to the sensor for collecting light to form an image. 

Increase this parameter when the light intensity is low.  
 

 

Figure 175 - Exposure Time control 

 

Display Information on Camera ( ): when enabled, this option will display 
on the live image the histogram, the saturation and the high background indicators. 

Display Scale bar ( ): when enabled, this option will display the scale bar on the live 
image. 

Display RGB value ( ): when enabled, this option will display the RGB value on the 
live image. 

 

Advanced Settings 

In order to access the advanced mode, right click in the area where the camera parameters are. The 

following menu will appear: . The Advanced tab will appear when checked.  

Binning: this parameter is used in order to decrease the size of the captured image and decrease the 
time needed for the capture operation. This will increase overall acquisition speed, but the image 
quality will be affected (reduced). 

 

Figure 176 - Binning combo box 

 

Flip: this parameter is used to flip the captured image. You can use this parameter to correct the 
orientation of the image, if the left/right or top/down of the camera are different that those of the stage. 
This parameter is generally adjusted when the system is installed. The FOV calibration feature is able 
to automatically set this parameter to its correct value. 

 

Figure 177 - Flip Image control 

Lower / Upper:  These parameters specify the interval which will be scaled to 256 gray levels for 
display.  

- Lower Sensitivity Threshold: by increasing this, the low intensities (like background) in the 
image will be lost. 
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- Upper Sensitivity Threshold: by decreasing this value, the shades in the image will 
become brighter. 

 

 

- If you want to manually adjust these parameters, you should set them in such a way 
that the lower parameter limit equals the smallest value for which the “High 
background” is green and the highest value for the upper parameter for which the 
“Saturation” indicator is green. 

- Lower/Upper control might be present for some installations within the Basic tab. 

 

  

Figure 178 - Lower / Upper parameters controls 

You can automatically adjust these parameters by pressing the Auto button. 

By choosing Advanced Options… the following dialog will appear:  

 

Figure 179 - Options for detect Lower / Upper Limit Parameters control panel 

The advanced options control how TissueFAXS detects the presence of oversaturation and 
undersaturation (lack of signal) in the camera image. 
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UnderSaturation Percent: If the number of pixels with intensity value higher than the (under-) 
saturation limit is over this percent of the total number of pixel then the image is considered 
undersaturated. 

Saturation Percent: If the number of pixels with intensity value higher than the (over-) saturation limit 
is over this percent of the total number of pixel then the image is considered oversaturated. 

UnderSaturation Value: The maximum acceptable intensity value for witch a pixel is considered 
undersaturated. 

Saturation Value: The minimum acceptable intensity value for which a pixel is considered 
oversaturated. 

6.6.9 Settings for Baumer Color Camera 

The settings available for the camera are divided in two categories: basic settings and advanced 
settings. Basing settings are the most frequently used, while advanced settings are rarely used and 
should only be changed by experienced users. Usually, advanced settings are only needed when the 
system is installed or in special conditions (as described in sections below). 

 

Basic Settings 

Exposure: The amount of time available to the sensor for collecting light to form an image. Increase 

this parameter when the light intensity is low.  

 

Figure 180 - Exposure control 

 
Use Auto on ROI option for difficult samples, in order to adjust the exposure value taking into account 
only a manually delimited area (a ROI). Press Auto on ROI button, then draw desired area. The 
exposure in your image will be automatically adjusted. 

 

Figure 181 - Selecting ROI on the sample 

 

White Balance: this parameter adjusts the intensity of the Red, Green and Blue colors in order to 
render a neutral color correctly (white is usually used as a reference). You can press Auto to auto 
balance the colors. When the transmitted light is not white, you can use this parameter in order to 
correct the hue of the light in order to obtain the reference white light. 

Use Auto on ROI option for difficult samples, in order to adjust the white balance value taking into 
account only a manually delimited area (a ROI). Press Auto on ROI button, then draw desired area. 
The white balance in your image will be automatically adjusted. 
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Figure 182 - White Balance control 

 
 

Display Information on Camera ( ): when enabled, this option will display 
on the live image the histogram, the saturation and the high background indicators. 

Display Scale bar ( ): when enabled, this option will display the scale bar on the live 
image. 

Display RGB value ( ): when enabled, this option will display the RGB value on the 
live image. 

Saturation: represents the purity or strength of a color, due to absence of black, white or gray. 
Adjusting color saturation will affect how intense the tones of the color are in your image. Use this in 
order to enhance colors on tissues with faded colors.  

The default value for Saturation is 150. If the user wants to set the default value for this parameter he 
must press the Default button. 

Use On checkbox to enhance saturation on the acquired images. The default recommended value is 
150. 

 

Figure 183 - Saturation control 

 

- Please note the fact that when On is enabled, the acquisition time will be increased 
with 100%. 

- When On is enabled, it will only bring up better looking images, bit will not have any 
effect on the quality of the acquired images. 

 

Advanced Settings 

In order to access the advanced mode, right click in the area where the camera parameters are. The 

following menu will appear: . The Advanced tab will appear when checked.  

 

Flip: this parameter is used to flip the captured image. You can use this parameter to correct the 
orientation of the image, if the left/right or top/down of the camera are different that those of the stage. 
This parameter is generally adjusted when the system is installed. The FOV calibration feature is able 
to automatically set this parameter to its correct value. 
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Figure 184 - Flip Image control 

Image Format: this parameter allows to select the image format used for the transfer.   

 

- Image format is not supported by all cameras. 

- You should modify this parameter only if advised by the support team. 

 

 

Figure 185 - Image Format control 

 

Gain: artificially adjusts the intensity of pixels (by software multiplication of pixel values). 

 

Figure 186 - Gain control 

Sensor saturation: This set of parameters has no effect on the final images. This sensor is used only 
to warn the user of possibly over saturated pictures that can later affect the illumination correction 
process. The two parameters are:  

- Max allowed values: if you have a very bright image that is considered oversaturated (the 
sensor turns red), you can increase this value in order to make the sensor accept it.  

- Sensor saturation area: if the number of bright pixels (with a value above maximum 
allowed) is lower than Sensor saturation area, the image is considered to be fine; otherwise, 
it is considered oversaturated. Generally, you might want to increase this value when 
working with samples having many bright areas. 

 

Figure 187 - Sensor saturation 

Target Brightness for auto exposure: this controls the brightness percent that must be reached by 
the auto exposure function. 
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Figure 188 - Target Brightness for auto exposure 

 

- Please note the fact that when you change the value for this parameter, only the last 
value used for auto-exposure will be remembered.  

 

6.7. Camera Panel  

The Camera Panel, one of the essential tools in TissueFAXS, contains the stage control, the camera 
controls and a panel where controls for the microscope can be dragged. This panel containing 
controls for the microscope proves to be very useful, as it allows you to have ready at hand exactly 
the controls you need at the moment. If you want to remove the controls from the camera-window, 
drag them into the dustbin above. You will be able to drag them again from the microscope panel if 
needed later. 

 

Figure 189 - Camera Panel 
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6.7.1 Stage control 

This panel helps you to accurately control the movement of the microscope’s stage. 

 

Figure 190 - Joystick control 

 

Stage control components 

• Joystick control: The four arrows of the Joystick control can be used to move the stage on 
the X and Y axis.  The adjacent Up and Down buttons control the Z axis and are used to 
focus on the current field of view. 

• Autofocus button ( ): by clicking this button, the software will perform autofocus on 
the current field of view.   

If pressing the arrow, the following options will be available: 

- Focus: TissueFAXS will perform autofocus on current FOV. 

- Force Full Focus: The last focus position is ignored and the focus is always searched in 
the full interval. This method will take more time, but the obtained results will be better in 
case of difficult samples and environment (e.g. samples with many tissue folds). 

- Set Focus Interval Around this Point: This is meant to automatically set the Z interval 
within +/- 200 around current Z position (the position where the tissue is in focus), in order to 
restrain the focus interval and to reduce the duration of the focus process. 

 

 

Figure 191 - Focus options 

 

• Edit Speeds ( ):  this button allows you to adjust the speed at which the stage 
is moving on X, Y and Z axis when using the hardware joystick, the joystick control or when 
the following commands are used: Go to this point, Go to this slide and Move one FOV.  
After you have adjusted the speeds, click the Done button to save them. If you want to 
cancel, just press Esc or click elsewhere outside the popup. (To adjust the stage speed 
during acquisition, go to Tools → Options → Scan Settings → Speed.) 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 122 of 211 

 Internal 
 

 

Figure 192 - Editing speeds for joystick and Z axis 

• Load ( ): this button moves the stage down to the load position, so you can add 
or remove slides. 

• Work ( ): this button moves the stage up to work position. 

 

- These stage controls work only with motorized focusing drive. 

- If you are working with a TissueFAXS i system, which uses an inverted microscope, 
the objective revolver will be moved down and up rather than the stage. 

 

6.8. amera Control 

The camera control can be used to operate the camera to display a live preview, capture images and 
adjust camera settings. 

 

Figure 193 - Camera control 

View live preview 

When working with TissueFAXS, you may choose to see the live image or to disable it, by simply 
using a checkbox. 

• To enable live preview check Live Image ( ); 
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• To disable live preview uncheck Live Image ( ). 

 

- Any time you press View button from the channel list, the Live Image will be enabled. 

- If the function Live Images is disabled during acquisition, the overall acquisition speed 
will slightly increase. 

 

Capture images (manual procedure) 

Before manually capturing an image (without using the automatic acquisition feature of the 
TissueFAXS software), you must first choose a location and filename by pressing the following 

button: .  Next, you are able to capture the image by pressing the  
button. 

 

- If the filename you want to create already exists, the TissueFAXS software will not 
overwrite the existing file. The new filename will be incremented by a numerical 
extension that will generate a file name that does not already exist. For example, if you 
choose the filename C:\image.bmp, your new image will be automatically saved as 
C:\image.bmp, and, if the file already exists, the name will be C:\image 001.bmp. 

 

Acquire Single FOV (manual procedure) 

Acquiring a FOV means capturing one image (in case of multi-color fluorescence - one image per 
reflector). Reflectors are to be found in the channels list in the Acquisition settings for the current 
experiment. It is necessary to have a current experiment created in order to acquire a single FOV. In 
addition, be sure that the camera settings for all reflectors have been properly adjusted before 
acquiring an image. 

 

Figure 194 - Acquire FOV panel 

Clicking on the right side of the Acquire button ( ) will pop-up the following menu: 

 

Figure 195 - Acquire FOV menu 

Pressing the Acquire button ( ) is the same as choosing Acquire Current FOV from the 
pop-up menu. 
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Figure 196 - Advanced Options for Acquire FOV 

You also have the possibility to adjust the Advanced Options. The first time you attempt to acquire, 
you will be prompted to go to the window shown above, where you will be asked to provide the 
following information: 

• The storage folder for your acquired images; 

• FOV Group Name, which acts as a naming template for files to be acquired; 

• Separators inside the filename (the character used as a separator should not be used as part 
of the filename provided by the user); 

• Counter is used to avoid duplicate filenames when pressing the Acquire button multiple times; 

• Channel (usually, it is the reflector name); 

• Format of the graphics file. 

 

- Filename Preview section contains the file or the list of files obtained after the 

acquisition process. At any time, you can press the  button to verify the 
validity of the filename in the specified location (e.g. if the name is valid, if you have 
specified an existing folder, if you have enough rights etc.). 

 

Camera Profile 

A Camera Profile represents a set of camera related settings that you can save for further use, in 
order make available different combinations of settings for the acquisition process.  

 

Figure 197 - Profile Options menu 
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• Save: the current camera settings can be saved in order to make them available for further 
use. You must specify a name and a short description for each profile. A default name is 
already generated. It contains the camera name and type, the objective magnification and the 
reflector selected on microscope; you can also add your own information to the already existing 
name. 

If “Save as default channel profile” is checked then all new experiments that will have 20x as 
acquisition objective will automatically load this profile for acquisition. 

If pressed, Acquire Correction Image button will acquire the correction image for the acquired 
images. For more details please see Chapter 6.16.5. 

 

- Acquire Correction Image button is only available for Transmission channel.  

 

 

Figure 198 - Save Profile dialog 

 

• Load: an existing camera profile can be loaded for a camera. You must select any profile you 
want from the existing list. 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 126 of 211 

 Internal 
 

 

Figure 199 - Load Profile dialog 

• Delete: if an existing camera profile is no longer needed, it can be deleted by selecting it and 
then pressing the Delete button. 

 

Figure 200 - Delete Profile dialog 

 

Save 

By pressing this button camera settings will be saved for the channel identified by current objective 
and current reflector. 
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Move by One FOV 

With these buttons you can move the live image exactly one field of view up/down or left/right (only 
available after stage calibration). 

 

Figure 201 - Move one FOV controls 

Double click to center 

Double-clicking on any point in the live image will center the image at that point. 

Adjust camera settings 

To adjust the camera settings click on the title of the settings page. 

 

Figure 202 - Adjust camera settings tab for PixeLINK and PCO PixelFly cameras 
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Figure 203 - Adjust camera settings tab for Baumer Color cameras 

 

 

Figure 204 - Adjust camera settings tab for Hamamatsu Orca Flash 0.4 Cameras 
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Figure 205 - Adjust camera settings tab for PCO PixelFly USB Cameras 

 

Press the  button from the lower right corner to close the tab. 

For more information please see Chapter 6.6 of the current manual. 

6.9. Drag-drop panel 

In this panel, you can drag and drop controls from the microscope panel that are used most 
frequently. If a control is no longer needed, it can be dragged and dropped on the remove button 

( ). When TissueFAXS is restarted, the last configuration is loaded. 

  

Figure 206 - Drag-drop panel 
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6.10. Camera settings for Preview and Acquisition 

To adjust the camera settings for Preview or Acquisition, click the  button for the 
desired channel and its current settings will appear in the camera panel. After you adjust the camera 

settings, click on the  button in the camera panel to save them. 

6.11. Making a preview  

You will be ready to capture a preview image of your slide when you have set up your experiment and 
adjusted your camera settings for your preview objective. To acquire, press the Preview button 

( ) located within your selected slide panel. 

To preview another slide or multiple slides, click on the drop-down menu of the Preview button for 
more preview options. 

 

Figure 207 - Preview options panel 

If Preview Multiple is chosen, the following dialog will appear: 

 

Figure 208 - Focus for Preview dialog 

Select your focus method then press OK.  In the next window, select the slides you wish to acquire.  

 

- Autofocus method will use the method defined in Options → Scan Settings → 
Focus.  If you check Do not show this dialog again, your current choice will be 
remembered for future use and you will not be prompted again. This selection can be 
reset from Tools → Options → Application Options → Remember. 
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Figure 209 - Slides selection checkbox 

 

6.12. Stopping a Preview 

To quit the preview, there are two options: you can abort the preview of the current slide in progress 
or the complete preview process.  

To quit the preview of the current slide (current selection), simply press the Preview button 

( ), which has turned into a power-off-button during acquisition. TissueFAXS will quit the 
current slide and move on to the next slide, if available. 

To quit the complete process, click the Preview Selected Slide button ( ) from the very top 
panel. 

6.13. Experiment Editor 

The Experiment Editor is the control located at the left side of the application’s main window.  Its 
purpose is to organize your slides, regions of interest and acquired images into one complete list.  
Regions of interests are displayed as thumbnails images in this list (see the image below). 
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Figure 210 - Experiment editor: Experiment with slides and regions 

From top to bottom, the editor consists of three main parts: a tree-like representation of the 
experiment, a property grid, and a description area. 

Experiment tree-like representation 

In TissueFAXS, you can draw a region on your preview image (with the rectangle, circle, or custom 
draw tool), as described in Chapter 6.15.1. The Experiment Editor will automatically display each 
new region in the tree list along with its corresponding thumbnail. This gives the user a visual 
overview of all regions of interest in the experiment (that can be acquired later). 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 133 of 211 

 Internal 
 

 

Figure 211 - Thumbnail for regions 

Grouping Regions 

This is one important feature of the Experiment Editor, allowing regions to be grouped together. This 
is particularly useful when you wish to distinguish multiple regions of interest that exist on the same 
slide. For example, you may have two patients’ tissue samples on the same slide and want to 
organize your regions/images into a group for each patient. To create a group, right-click on the slide 
in the list and select Create Group. Once created, the group can be renamed and regions can be 
dragged and dropped into the respective group.    

 

Figure 212 - Creating groups context menu 

Right-clicking on items in the menu allows you to directly acquire or remove them from the 
experiment. 
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Acquire experiment item 

Clicking on this option allows you to directly acquire the selected experiment item. 

Remove 

Clicking on this option allows you to directly remove the selected item from the experiment. 

Remove Regions 

Clicking on this option allows you to directly remove all items from the selected slide/group from the 
experiment. 

Build/Clear Cache for Slide 

Builds/clears cache for the selected slide. 

Remove Acquired Images 

This option will erase all the acquired images and associated files from the storage area. Notice the 
fact that this option is available only for acquired regions. 

Propagate region/slide to slide… 

This option copies selected regions from a slide to other slide/slides that you can select in the dialog 
below: 

 

Figure 213 - Slide selection for propagation checkbox 

 

- You can select any slide to propagate regions, except for the slides that appear 
disabled in the Slide Selection dialog.  

- A slide appears disabled because: 

- It is the slide containing the original regions to be propagated afterwards (you 
cannot propagate a slide to itself); 

- The content type is different from the type of the slide containing the original 
regions to be propagated. 

 

The dialog contains another option (All items) that will select all available slides. 

 

- The propagated regions will not have corresponding thumbnail images. 
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Export… 

To find out more about this option, please see Chapter 6.19 of the current manual. 

 

- For certain operations (acquisition, propagation, export) you have the possibility to use 
the multiple selection. 

 

Plugins (see Chapter 6.20) 

Compute Stitch (see Chapter 4.3.2) 

 

Property Editor 

The properties section is located below the tree-list. More precisely, it is a property grid that shows all 
the properties available for a specific project item. 

A project item can be a slide, a region, a group and the experiment itself. Some of the properties 
displayed in the properties grid are editable, others are read-only. Here, you may change/create 
names for slides, groups, and regions. The user can also choose to include/exclude a region in the 
acquisition process or determine if the region is already acquired. 

 

Figure 214 - Region properties section 

In the example above, the region has the following properties: 

• The item is acquired; 

• The item is not acquired with time lapse; 
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• Area: total area of the region (including only acquired fields of view); 

• Area in ROI: area for the cropped shape (including only acquired fields of view); 

• The acquisition date; 

• The comment indicates sample related data; 

• The item consists of a virtual matrix containing 6x6 Fields of View; 

• The FOV size (Width and Height); 

• The item is included in acquisition; 

• The item name; 

• Data concerning the patient; 

• The type/shape of the region is rectangular; 

• The storage directory is shown here; 

• Time lapse: number of runs and time lapse are shown here; 

• The total magnification; 

• The type of selected item is Region; 

• Stitch. 

 

- By selecting more items at the same time (multiple selection), all the common 
properties shared by these items can be simultaneously modified in order to have the 
same value. 

- Some of the items from the Property Editor are not editable (they appear in grey). 

 

 

- The properties of an experiment can be displayed by going to File → Properties.... In 
the dialog that appears, only the Comments concerning the experiment can be edited. 

 

 

Figure 215 - Experiment Properties dialog 
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6.14. Slide Manager 

The Slide Manager is a feature that allows a quick and simple access to the main slide settings. 

It can be accessed from: 

•  File → Slide Manager 

 

Figure 216 - File Menu: Slide Manager option 

• Experiment Editor: right click on the name of the experiment and choose Slide Manager option from the 
contextual menu. 

 

Figure 217 - Experiment Editor: Slide Manager option 

 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 138 of 211 

 Internal 
 

In both cases the Slide Manager dialog will open: 

 

Figure 218 - Slide Manager dialog 

Here you can perform the following actions: 

• Change the name of the slide: type the new name into the New Name field of the desired slide; 

• Include the slide in acquisition by checking the corresponding checkbox in the Included in acquisition 
column; 

• The Content type column informs you about the type of each slide; 

• You can also add a comment to each slide by typing it into the Comment field of the desired slide. 

  

6.15. Slide Editor 

The slide editor is one of the main features of the TissueFAXS application. It displays the image of 
the whole slide and also a panel with all the applicable functionalities. 
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Figure 219 - Slide Editor in the main window 

 

A slide preview must be acquired to use the slide editor. You can perform a set of operations on a 
slide by right-clicking on it and generating a pop-up menu, as shown below: 
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Figure 220 - Slide editor context menu 

 

6.15.1 Add Region  

In this section you will learn how to draw regions on your slide. This option yields a submenu which 
contains four types of drawing tools. 

 

Figure 221 - Add region context menu 
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There are four different methods for drawing your regions of interest: 

• Custom - This method allows the user to create a custom shaped region with a rubber-line 
tool.  The tips of the line are made static by left clicking on the image.  Simply right click 
anywhere to close your region. 

 

Figure 222 - Creating custom region 

• Rectangular - This method allows the user to simply drag a box over the image to create a 
rectangular region.  A start point and an end point are chosen by left clicking on the image. 

   

Figure 223 - Creating rectangular region 

• Circular - This method requires two left clicks to create a circular region. The first left click 
determines the center while the second click determines the radius of the circle. 

 

Figure 224 - Creating circular region 

• Custom (with joystick) - This method allows you to draw the region shape by using the 
hardware joystick. When you select this, the following dialog will appear:  
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Figure 225 - Custom region with joystick dialog 

 

Move the joystick to the desired points and for each of them click the Add Point button. When you 
wish to close the region, click the Close Region button. Usually, this function is used in conjunction 
with Live image (using a high magnification in order to increase the precision of the region shape).  
You can click anytime the Cancel button to reject any changes you have made. 

6.15.2 Modify Region 

All created regions can be modified (resized, moved) as long as no images have been acquired for 
them.  

• The move whole region operation can be performed in 2 steps: 
 

1. Select the region by right clicking an inner point of its shape; 
2. Click and hold the right mouse button in the same spot to begin the drag and drop operation. 

 

Figure 226 - a) Click an inner point of the region 

b) Drag&Drop operation to move the region 

 

• The resize or reshape operation: 

Each region has special points that can be dragged in order to resize it or to change its shape, 
depending on the region type, as described below:  

 

- For all the regions, these points can be seen when the mouse hovers above the 
region. 

 

For Custom Regions, only the currently selected point can be moved (it appears marked by a little 
black cross, like in the image below), so you have to modify all desired points one by one in order to 
reshape the region.  
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Figure 227 - a) Resize (move point) custom region 

b) Drag&Drop operation to move the point 

 

For Rectangular Regions, the entire rectangle is resized when you move the selected point (it 
appears marked by a little black cross, like in the image below). 

 

Figure 228 - a) Resize (move point) rectangular region 

b) Drag&Drop operation to resize the rectangle 

 

Likewise, Circular Regions are resized by moving the selected point (it appears marked by a little 
black cross, like in the image below). 

 

Figure 229 - a) Resize (move point) circular region 

b) Drag&Drop operation to resize the circle  
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• Remove Region: right-click on the region and choose Remove Region. 

• Remove acquired images: this option will erase all the acquired images and associated files 
from the storage area. Notice the fact that this option is available only for acquired regions. 

6.15.3 Copy and Paste region 

• Copy Region: this operation can be done by choosing the Copy option from the region 
contextual menu or by using the Ctrl+C combination from the keyboard. 

• Paste Region: this operation can be done by choosing the Paste option from the region 
contextual menu or by using the Ctrl+V combination from the keyboard. 

 

- It is possible to select multiple regions to be copied, by using the mouse selection. 

 

 

Figure 230 - Multiple selection of regions to be copied 

6.15.4 Preview Area  

 

A region can be set as a preview area for future preview operations in the current experiment. 
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Figure 231 - Set new preview area context menu 

 

If the preview area chosen in the experiment setup needs to be adjusted, a rectangle can be drawn 
on the slide, clicking the left mouse button to accept a drawn rectangle. Right-clicking within the 
selection will allow doing the following: 

• Set region as preview area - set current region as preview area for current experiment. This 
will affect all subsequent slides in this experiment. 

• Save region as preview schema - saves current region as preview area for future use and set 
it as preview area for current experiment. You can give a name to this preview scheme and 
store it (to use it again in future experiments). 

• Add as rectangle region - creates a region that will be acquired later. 
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Figure 232 - Preview Area context menus 

6.15.5 Stage Menu 

By right clicking on any of the slide images, you will obtain a contextual menu including more options, 
as seen in the image below: 

 

Figure 233 - Stage Control: context menu 
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This contextual menu will help you better manage the physical stage and control the acquisition 
process. 

• Go To This Slide -To make the objective lens physically move onto a particular slide, you must 
right-click on the slide and choose Go to This Slide.  In the main window, a green box will 
outline the slide that is currently in observation position. 

• Go To This Point - To make the objective lens physically move to a specific location on a 
slide, right-click on that point and choose Go to This Slide. This is particularly useful for 
navigating through acquired slide previews and for determining where to draw regions of 
interest in the Custom (with Joystick) mode. 

• Acquire Slide - this item starts the acquisition process. Its target is the selected slide only. 

• Acquire Region - starts the acquisition process for the selected region only. 

• Label Up / Label Down - The Label Up and Label Down entries allow you to specify the 
position of the slide on the stage. Usually, all the slides are inserted in the same way, but if this 
is not the case, the label position can be customized for individual slides on the stage. 

• Show position on slide ( ) - You have the option of viewing the objective’s position on 
the slide in relation to your preview, by selecting Show position on slide in the menu.  An 
orange box appears indicating the size of one field of view along with cross interrupted lines 
that mark the center. The FOV size is determined by the objective in use. If the FOV is not 
calibrated for the selected objective, the box will have the default size. 

 

Figure 234 - Show position on slide 

• Show preview info ( ) - By pressing this button, you will be able to see the location of 
the preview area (common for all slides) on the slide and the position of the focus point (for 
each individual slide) for preview operation. You can also access this option from the 
contextual menu that appears when right clicking in the slide editor. 

• Set as preview focus point - Use this option to set the focus point to the desired position, by 
right clicking the respective point. 
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Figure 235 - Set as preview focus point context menu 

• Reset focus point… - use this option to reset the focus point to the default position (center of 
preview area). 

 

Figure 236 - Reset focus point context menu 
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- You can reset the focus point for the current slide or for all slides. 

 

 

Figure 237 - Reset focus point dialog 

6.15.6 Export this slide image… 

To export a slide’s preview image, select Export this slide image from the menu. You will be 
prompted to choose the destination directory and the encoding type for the image. For more details 
concerning this feature, please see Chapter 6.19.4 of the current manual. 

6.15.7 Automatic tissue detection  

After the preview is done, TissueFAXS is able to auto-detect the tissue regions on the slide. This is a 
great tool provided by TissueFAXS that can help you save time and improve the accuracy of the 
tissue detection. 

In order to detect generic tissue samples, please make sure that the Content Type property of the 

slide is set to Generic. Then press Detect Tissue button ( ) from the slide editor toolbar. The 
following dialog will appear: 
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Figure 238 - Tissue Detection panel 

By default, the detection is run on the entire preview image. If you want to refine the results, you can 
run the detection on a smaller area: 

• select the desired area by drawing it on the displayed image; 

• click on Run Selection.  

If you want to cancel selection, press the Clear Selection button.  

Detection Parameters 

 In order to refine the results of the automatic detection, TissueFAXS provides a set of parameters 
you can adjust according to your needs, in order to obtain the desired results. 

• Minimum Tissue Area: the smallest area a tissue region can have. All the regions with a 
smaller area will not be taken into account.  

• Tissue Closing Radius: try to increase this parameter if your region is split into multiple small 
subregions. The result will be a single region containing smaller subregions. 

• Exclude border connected regions: the regions touching the border will be ignored. 

• Regions: number of regions expected to be detected. 
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• Default: this dropdown button has more options: 

 

Figure 239 - Tissue Detection: Default Parameters 

 

- Save as Tissue Detection Default Parameters: it allows  you to store this set of 
parameters values for future detection. 

- Restore Tissue Detection Default Parameters: it restores all the parameters to the last 
saved default parameters. 

- Save as Tissue Detection profile: saves the current parameters settings for further use. 

- Load Tissue Detection Profile: loads a previously saved profile. 

 

Figure 240 - Loading tissue detection profile 

Advanced Settings 

• Thresholds 

- Automatic: if this is checked, the RGB (red/green/blue) channels values are automatically 
determined within three intervals given by the user. These intervals are established by 
increasing the lower (default value is 5) and upper (default value is 255) values. 

If Automatic option is unchecked, the tissue detection algorithm will use three values given by 
the user for Red, Green and Blue channels. 

- Apply same value for all channels: by checking this option, all channels will have identical 
values or intervals (you must set the value or interval for the red parameter, this value or 
interval will appear automatically for the other two channels); 

- Red: the amount of red in the picture; 

- Green: the amount of green in the picture; 

- Blue: the amount of blue in the picture. 
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- Depending on the color used in the staining, different adjustments of the Red, Green 
and Blue values might become necessary. 

 

 

Figure 241 - Advanced Settings: Thresholds tab - Automatic checked 

 

Figure 242 - Advanced Settings: Thresholds tab - Automatic unchecked 

 

• Point Generation 

- Distance: the initially detected region will be inflated with the specified number of pixels, in 
order to entirely include the edges of the tissue and a small surrounding area; 

- Max Step: this parameter represents the maximum distance between two generated points. 
The smaller the distance is, the more accurately the contour of the region will be represented. 
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Figure 243 - Advanced Setting: Point Generation tab 

For more accurate tissue detection the following controls are available:  

• Zoom in and Zoom out buttons allow zooming the image. Another option would be to type the 
desired zoom value in the zoom editor. 

• View Original Size: displays original size of the image. 

• View Best Fit: displays the entire region. 

 

6.15.8 Slide Overlay  

Located in the toolbar, the Slide Overlay button ( ) will allow you to view your preview image 
for each reflector/channel (in fluorescence experiments). Check the desired reflector in the panel 
shown below in order to obtain the desired preview. 

 

Figure 244 - Slide Overlay Dialog 

6.15.9 Custom Selection 

Custom Selection button ( ) allows the user to freely draw a selection over the sample in order 
to select the desired group of ROIs. This feature helps avoiding multiple clicks for one-by-one 
selection of the desired items. 
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Figure 245 - Custom Selection 

6.16. Region Viewer 

A region is an array of FOVs disposed in a matrix structure. Each FOV has its own position within the 
matrix, which represents the number of rows and columns. The FOV Matrix Size property of the 
region represents the number of rows and columns. 

To view acquired regions, double-click on the region from the experiment editor (on the left side of the 
main window). The region viewer panel, which was empty before, will be updated with the region’s 
image. The Region Viewer is shown in the next screenshot: 
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Figure 246 - Acquired Images viewer (Fluorescence experiment) 

The slide name and region name are displayed at the bottom left corner of the region viewer. 

In fluorescence experiments, the  button is enabled. Clicking on it yields a new 
window, as shown below: 

 

Figure 247 - Adjusting channel intensity and color 

This window allows you to choose which channels to view in your acquired image. Here, you can 
adjust the color and light intensity for each channel. If more than one channel is selected, clicking 
Apply will yield an overlay image, which is composed of the selected channels according to the set 
algorithms. 

In brightfield experiments, the Region Overlay… button is disabled because there is only one image 
for each Field Of View. 
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Zoom in and Zoom out buttons allow zooming the image. Another option would be to type the 
desired zoom value in the zoom editor. Keep in mind, however, that the Region Viewer is designed to 
give the user an overview of the entire region and therefore is limited in giving detailed magnified 
images. 

After a region is acquired, the user can double press the left mouse button on the region to open the 
Acquired Image tab and to see the acquired image splitted into Fields of View. 

The toolbar contains the following buttons:  

• Export: Fields of View, Region Overview; 

• Plugins; 

• Zoom in; 

• Zoom out; 

• Map: shows/hides region map; 

• Add subregions and tissue areas belonging to categories; 

• Subregions: Show Defined Regions, All Categories, Manage Categories; 

• Crop (it marks the images that have been acquired outside the defined region); 

• Gridlines: default value is Off ; 

• Scalebar: default value is Off; 

• Measure; 

• Annotations; 

• Illumination Correction; 

• Reacquire Flag; 

• Add Flag (it adds Fields of View to the region); 

• Remove Flag (it removes Fields of View from the region); 

• Time lapse acquisition button (if it is the case). 

To view a more detailed, high resolution portion of the acquired image, double click on it.  This will 
create a new window called the Field of View Viewer (see next section). 

6.16.1 Subregions 

Subregions are normal regions defined within the Region Viewer, having the same properties as the 
regions from the Slide Preview. You can see them in the experiment editor and they can be acquired 
just like normal regions. The advantage of the subregions is to ensure higher flexibility and more 
detailed analysis on a more detailed area of tissue. 

To add subregions, go to Region Viewer Toolbar → Subregions →Show Defined Regions (only 
Show Defined Regions should appear checked). 
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Figure 248 - Add Subregions context menu 

Now, choose the subregion shape from the toolbar ( ). Then add the desired 
subregion on the viewer using the mouse, just like for any normal region (see Chapter 6.15.1). 

To be able to see all subregions you have added, simply check Show Defined Regions option from 
the Region Viewer Toolbar. 

6.16.2 Categories 

Sometimes, you may want to emphasize certain small areas on your region that could contain high 
interest information for your research. These areas can be exported for analysis or they can be used 
as a highlight tool.  

For instance, a tissue may contain both tumor areas and normal adjacent tissue (non-tumor) areas. 
For each type of area (e.g. tumor, non-tumor) you may create a category in order to highlight that 
particular area on the image. 

Using categories might help you in order to perform a precise analysis.  

Add categories 

In order to add categories, go to Region Viewer Toolbar → Subregions → Manage Categories… A 
dialog will appear (containing already added categories, if existing) where you can add new 
categories, giving each one a name (mandatory) and assigning a color. The list of categories is per 
project, not per region. 

 

Figure 249 - Add categories dialog 



 
 

TFAXS - V4.2 - USER MANUAL / 1.0 
TissueFAXS 4.2 

 

TissueFAXS 4.2 USER MANUAL V1.0 Page 158 of 211 

 Internal 
 

 

Figure 250 - Region Viewer: example of categories 

You may also use the categories when you are about to export images. For further details please see 
Chapter 6.19 of the current manual.  

 

- All existing categories are listed in the Subregions menu. 

 

Remove categories 

In order to perform this action, go to Region Viewer Toolbar → Subregions → Manage 
Categories… and select the category you want to remove, then press the Delete key from your 
keyboard. 

Apply categories on regions 

To create these areas, go to Region Viewer Toolbar → Subregions, then select only the desired 
category. 

Now, choose the area shape from the toolbar. 

 

Figure 251 - Toolbar: categories shapes 
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Then add the desired area on the viewer using the mouse, just like for any normal region (see 
Chapter 6.15.1). 

Once created, these areas cannot be modified, only removed. To remove the areas, right click inside 
the desired area and then choose Remove [area name]… 

  

Figure 252 - Remove category area context menu 

 

View / hide categories on regions 

To be able to view all tissue areas belonging to a certain category, check only that particular category 
in Region Viewer Toolbar → Subregions. 

If you want to see all existing categories, check All Categories option from Region Viewer Toolbar 
→ Subregions. 

To hide the tissue areas belonging to a category, simply uncheck that particular category in Region 
Viewer Toolbar → Subregions. 

Export tissue areas belonging to categories 

• When exporting the Region Overview, you have the possibility to choose an option that also 
exports the categories.  

• When exporting the FOVs images, you have the possibility to choose an option that only exports 
the images belonging to the respective category.  

For more details please see Chapter 6.19 of the current manual. 

Transforming regions from categories into subregions for reacquisition 

If the user needs to reacquire the tissue area from a category, it is possible to transform it into a 
Defined Region and then perform reacquisition.  
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In the region viewer, right click on the border of a category and from the contextual menu choose 
Transform into Defined Region option. The category will transform into a Defined Region, it will 
disappear from the region viewer and it will be visible in the experiment editor, so it can be reacquired. 

 

Figure 253 - Transform region from a category into a subregion for reacquisition 

6.16.3 Annotations 

Press the Subregions ( ) button in order to access the Subregions contextual menu.  

The following options will be available: 

 
 

Figure 254 - Annotations contextual menu 
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Show Annotations  

To add annotations, go to Region Viewer Toolbar → Subregions →Show Annotations (only Show 
Annotations should appear checked). 

Now, choose the annotation shape from the toolbar. Then add the desired shape on the viewer using 
the mouse, just like for any normal region (see Chapter 6.15.1). 

To be able to see all annotations you have added, simply check Show Annotation option from the 
Region Viewer toolbar. 

PolyLine Measurements 

This feature allows drawing a line shape in order to measure a certain area.  

Press PolyLine button and draw desired shape on the sample (see Chapter 6.19 for more details). 

 
 

Figure 255 - Drawing PolyLine 
 

Manage Annotations 

 

Figure 256 - Edit Annotations dialog 

• Locate: by pressing this button, the selected annotation will be located on the sample and displayed at the 
current size of the sample. 
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• Best Fit: by pressing this button, the selected annotation will be located on the sample and displayed at the 
current size of the region viewer. 

• Remove: removes the selected annotation. 

• Remove all: removes all existing annotations. 

• Please insert annotation content below: write desired content for the respective annotation. 

 

Edit annotation directly on the sample 

An annotation can also be edited directly on the image viewer: it can be renamed, its content can be 
changed or it can be removed. To edit an annotation you must use the little black framed square on 
the contour of the annotation. If pressed, this little square will display an edit box, where you can 
operate the following actions: 

 

Figure 257 - Edit annotation directly on the sample 

• Edit the name of the annotation: write the desired name in the upper-left corner of the box, then press Enter 
key to save the changes; 

• Write a comment in the space below the name, you can also erase the existing comments (all the changes 
concerning the notes are automatically saved); 

• Delete the annotation by pressing  button; 

• Close the edit box by pressing  button. 

 

Export Annotations (please see Chapter 6.19.5) 

 

6.16.4 Save/Copy Displayed Image 

Save Displayed Image 

In TissueFAXS, you can save the image displayed in the region viewer by choosing Save Displayed 
Image... option from the contextual menu. You can choose Save Displayed Image if you simply want 
to save the image or you can choose Save Displayed Image with Data if you want to save the image 
with all its details (for example regions, annotations, flags etc.). 
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Figure 258 - Save Displayed Image 

In both cases TissueFAXS will ask you to choose a location, a name and the format type for the 
image to be saved and you will receive a message box like in the image below. 

 

Figure 259 - Save Displayed Image message box 

 

Copy Displayed Image 

 

You can copy to clipboard the image displayed in the region viewer by choosing Copy Displayed 
Image... option from the contextual menu. You can choose Copy Displayed Image if you simply want 
to copy the image or you can choose Copy Displayed Image with Data if you want to copy the 
image with all its details (for example regions, annotations, flags etc.). 
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Figure 260 - Copy Displayed Image 

6.16.5 Illumination Correction (Shading Correction) 

Occasionally, on the acquired images, some shades may appear. They can be caused by 
imperfections of any component of the lightpath, specks/impurities on the camera/objective.  

TissueFAXS allows you fixing such shading problems by using the Illumination Correction function. 
In this chapter, you will find how to use this feature. 

 

- This operation is available only for brightfield experiments. 

 

You can access the Illumination Correction menu by pressing the Illumination Correction button 

( ) from the Region Viewer control. 

To apply illumination correction, a correction image is required (mandatory). 

The correction image is an image computed in order to store information about the shades in the 
light path. By applying this image to a certain region, the shades will be eliminated and the images will 
be uniformly illuminated.   
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Figure 261 - Illumination Correction menu 

The Illumination Correction menu contains the following items: 

• Illumination correction: choose this option to automatically apply the correction image to your 
region. If there is no correction image available, you will receive a message box that offers you 
three possibilities: 

- Compute a correction image, using the already acquired images; this is the solution when a 
correction image is not available and reacquiring the correction image with the same 
settings/hardware as the region is not possible anymore. 

- Acquire a correction image (this is equivalent to Reacquire correction image from the 
Illumination correction menu); 

- Cancel the whole process of illumination correction. 

 

Figure 262 - Compute correction image message box 

 

• Select correction image: by choosing this option, you will be displayed a dialog where you can 
choose from the listed regions (containing correction image) the one you want as correction 
image.  

 

 

- The region that appears in red in this dialog is the currently opened region 

 
After selecting the respective image, you can effectively apply the illumination correction. 
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Figure 263 - Illumination Correction: Select correction image 

• Reacquire correction image: this option should be used when you wish correcting the 
illumination for an already acquired region. The following panel will appear: 

 

Figure 264 - Acquire correction image control panel 

- Correction region size: you can specify here the width and the height, expressed in 
FOVs, of the area used to compute the correction image. Generally, a large area size 
is to be preferred, but this is not mandatory. 
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- Overlap: the overlap parameter helps you control the size of the overlapping area 
shared by neighboring FOVs that form the correction region. You can adjust the 
number of pixels that can be shared (overlapped) by two FOVs by using the slider. 
Usually, by increasing the value, you can obtain a better correction image, and thus, a 
better illuminated region.  

- Press OK button to save the correction image or Cancel button to cancel the 
acquisition process. 

 

• Apply this correction image to the entire experiment: the correction image of the 
current region from the region viewer will be applied to all regions of an opened experiment. 

 

 

- Each time, before starting the acquisition process, you will be displayed an 
Acquisition Information dialog where you can check the Acquire correction image 
option in order to obtain a correction image for the respective region. TissueFAXS will 
use the same acquisition settings for the region and for the correction image. 

 

 

- The correction image must be acquired on an area with no tissue. Also you must not 
be positioned near the slide margins 

 

 

Figure 265 – Acquisition Information : Acquire correction image check box 
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The Shading correction images acquisition dialog will appear (see above the Reacquire correction 
image paragraph). 

 

- If you frequently acquire correction image you can set this option as default from Tools 
→ Options → Application Options →Remember.  

 

6.16.6 Flags 

In TissueFAXS, the flag option is used in the reacquisition of the FOVs, when the initial acquisition 
process has generated unclear or unsatisfying results. 

By using the flags, you can modify the shape of your region by adding or removing FOVs.  

 

Figure 266 – Region Viewer Toolbar 

Reacquire Flags 

In order to view and manage the flags, you must first ensure the Set Flag button ( ) from region 

viewer toolbar is pressed ( ). 

To add flags you have two options: 

• Directly left-clicking on the FOV you choose for focus; 

• By pressing Set “Reacquire Flag” from the contextual menu that appears when right clicking on 
the FOV chosen for focus. 

For both adding flags methods, the selected FOV will be set as a focus point and all its neighboring 
FOVs will be selected for reacquisition as well. The size of the neighboring area is the size specified 
by Tools → Options → Scan Settings → Focus → Focus Strategy Neighbors. 

To remove flags you have three options: 

• Directly left-clicking on the FOV; 

• By pressing Clear “Reacquire Flag” from the contextual menu that appears when right clicking. 

• By pressing Clear All “Reacquire Flags”… from the contextual menu that appears when right 
clicking and then choosing one of the three available options: For Current Region, For Whole 
Slide, For Entire Experiment. 
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Figure 267 – Clear All “Reacquire Flags” context menu 

 

- For the first two remove flags options, you may notice that by clicking on the focus 
flag, all neighboring flags will be removed (including the focus flag itself). However, by 
clicking on a neighboring flag (non focus flag), only this flag will disappear. 

 

 

Reacquire FOVs 

• If you choose the Reacquire This FOV Only option, only the current selected FOV will be 
acquired. 

• If you choose the Reacquire Flags option, you have three choices: For Current Region, For 
Whole Slide, For Entire Experiment. 
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Figure 268 – Reacquire Flags contextual menu 

Add Flags 

By adding flags, the size of the region will be enlarged in order to include new tissue area that could 
be relevant for analysis. 

As previously mentioned, FOV Matrix Size property of the region represents the number of FOVs per 
row and column. Based on the shape of the region, a part of these FOVs are not acquired.  

Adding flags without changing the FOV matrix size property: 

• Check the Add flag button ( ), then click on an empty position outside the region shape you 
might be interested in (next to already existing FOVs) but inside the crop area. To remove the 
added flag, click again on the same empty position. After finishing this operation, uncheck the 
Add Flag button. 
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Figure 269 – Adding flags without changing the FOV matrix size (a) 

 

  

Figure 270 – Adding flags without changing the FOV matrix size (b) 
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Adding flags by changing the FOV matrix size property: 

• If you click on the first/last row, you can select Insert row before/after; 

• If you click on the first/last column, you can select Insert column before/after; 

• Check the Add flag button ( ), then click on an empty position outside the region shape you 
might be interested in (next to already existing FOVs). To remove the added flag, click again on 
the same empty position. After finishing this operation, uncheck the Add Flag button; 

• You can also click Flag to add entire row/column from the contextual menu that appears by 
right clicking on the newly inserted row/column. To reverse this operation, choose Unflag entire 
row from the contextual menu; 

 

Figure 271 – Adding flags by changing the FOV matrix size (a) 

 

Figure 272 – Adding flags by changing the FOV matrix size (b) 
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• To remove all added flags, click Clear “Add Flags” ( ) from the Region Viewer toolbar or 
choose Clear “All Add Flags” from the contextual menu. 

 

Remove Flags 

• Check the Remove flag button ( ), then click on a border FOV you don’t need. To uncheck 
the added flag, click again on the same FOV. After finishing this operation, uncheck the Remove 
Flag button. 

 

Figure 273 – Remove flags (a) 

 

Figure 274 – Remove flags (b) 
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• You can also click Flag to remove entire row/column from the contextual menu that appears 
by right clicking on the border row/column. To reverse this operation, choose Unflag entire row 
from the contextual menu. 

• To remove all added flags, click Clear “Remove Flags” ( ) from the Region Viewer toolbar or 
choose Clear “All Remove Flags” from the contextual menu. 

Apply 

Pressing the Apply button ( ) will effectively modify the region shape by adding/removing FOVs 
(will remove images files too). 

Undo 

Pressing the Undo button ( ) will discard all changes (insert rows/columns, Add/Remove Flags). 

Acquire New FOVs 

This option from the contextual menu will acquire all newly added FOVs. 

 

- The Flags feature is not compatible with the Time Lapse acquisition and therefore it is 
available only for Standard acquisition mode. 

 

6.17. Field of View Viewer 

To view a detailed, high resolution section of an acquired image, double click on it within the Region 
Viewer window.  This will create a new window called the Field of View Viewer (FOV Viewer).  

 

Figure 275 – FOV Viewer (Fluorescence Experiment) 
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The features in the FOV Viewer are similar to those of the Region Viewer. The difference is that the 
FOV Viewer gives higher resolution images because it displays the original acquired image directly 
(and not just a thumbnail image, as with the Region Viewer). 

The user can navigate to neighboring FOVs with the arrow buttons at the top right corner of the 

viewer: .   

 

- The FOV displayed will be highlighted within the Region Viewer. 

- In the eventuality that the image does not fit the screen, drag it by using the hand tool 
instead of scrolling up/down or left/right. To do this, hold the right mouse button down 
and drag the image, then release the mouse button to stop. 

- Similar with the region viewer, use the trackbar to see the FOV at a certain moment by 

moving the cursor (  ). This option is 
available only if the FOV was acquired with time lapse (for details please see Chapter 
6.3.2). 

 

6.18. Field of View Viewer – Overlay feature (Fluorescence) 

The Overlay… button in the FOV viewer button displays the same dialog for adjusting channels 
intensities and colors as for the Region Viewer (see previous section). 

 

Figure 276 – Overlay Settings for a single FOV 

The difference is that the Apply button can work on multiple items as shown in the image below: 

 

 

 

 

Figure 277 – Apply overlay menu 
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Figure 278 - FOV Overlay: Example of adjusting color for one channel 
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The user can also adjust the intensity for each channel, by typing the desired value in the 

corresponding field ( ). 

6.19. Export 

TissueFAXS allows exporting acquired images as a complete region overlay or image by image. 

In certain cases csv files can also be exported. 

6.19.1 Export FOVs Images 

You can access this option in two ways:  

• Region viewer → Export → Fields of View; 

 

Figure 279 - Export FOVs Images Option (a) 

 

• Experiment Editor → Region Context Menu. 

 

Figure 280 – Export FOVs Images Option (b) 

 

 

- If you want to export more regions or FOVs simultaneously, you can select multiple 
items from the Experiment Editor tree. 

- You can also select Experiment item from Experiment Editor tree to export all the 
regions or FOVs. 
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In both cases, the following dialog will appear: 

 

Figure 281 – Export FOVs Images dialog 

TissueFAXS allows you configure the export as you desire, by choosing exactly the contents that is 
of interest to you. In the dialog displayed above, you can adjust the following settings: 

• Select the storage folder; 

• Select files to be exported:  

- Images 

- Movies (option available only if the region was acquired with time lapse) 
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- Use stitch 

• Select the file name convention (Name Parts, Custom Part, Parts, Image Format, Name 
Preview); 

• Select the type of images you want to save: 

- Overlay – The FOV images will be composed from all the channels as currently specified in 
region viewer. 

- Original – The FOV images will be exported separately for each channel as they were 
acquired.  

• Select what images will be saved: 

- All; 

- Flags Only and Flags with Neighbors (these options are available only if you have at least 
one flag set). 

• Invert selection – Only the FOVs not marked with flag or neighbors of the flagged FOVs 
(applies if  Flags with Neighbors is selected) are exported; 

• Export only FOVs belonging to categories: in this case, only the FOVs that belong to the 

selected categories are exported, by pressing the browse button ( ). 

 

Figure 282 – Export FOVs: Categories included  

 

 

- In the selection list, only those categories will be listed that contain tissue areas on 
their overview image. 

 

• Mark Crop Area: it marks the contour of the region for FOVs near the region border; you can 
also select its color; 

• Scale bar: please see Chapter 4.1.2 of the current manual. 

• Apply Illumination Correction: this option is enabled only for Brightfield experiments. The 
correction image will be applied to exported images if the correction image is available. 
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6.19.2 Export Region Overview 

You can access this option from:  

• Region viewer → Export → Region Overview; 

• Experiment Editor → Region Context Menu. 

 

- If you want to export more region overviews simultaneously, you can select multiple 
items from the Experiment Editor tree. 

 

The following dialog will appear: 

 

Figure 283 – Export Region Overview dialog 

 

Some information is displayed for each region: name, size, uncompressed size, estimated size. If 
one of the regions is too large, the respective region will be highlighted in red. 
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TissueFAXS allows configuring the export as desired, by choosing exactly the contents of interests. 
In the dialog displayed above, the user can adjust the following settings:  

• Select the storage folder; 

• Select files to be exported:  

- Images 

- Movies (option available only if the region was acquired with time lapse) 

 

• Enter Custom Part: type desired custom part for the name of the exported item. 

 

- The file name to be exported consists of a default part and a custom part. The default 
part consists of items from the File Name Convention (see Chapter 4.2.3). The custom 
part is defined by the user. 

 

• Select the file extension: choose exported item format (also available: .tiff with multiple tiles in 
order to export bigger images); 

 

Figure 284 – Export Region Overview: Extensions 

If choosing as extension the tiff with multiple tiles, the items from the Options for tiff with multiple files will be 
enabled: 

- Tile size: the dimension of an image (tile) composing the tiff (there are three predefined options); 

- Compression: there are two options – None and jpeg. 

- Quality: the quality of the compression can be adjusted using the slider. 

 

 

- If choosing as extension the tiff with multiple tiles, the following options will not be 
available anymore: Mark Crop Area, Scale bar, Include Categories. 

 

• I want to stitch thumbnails: choose this to export a low resolution of the region; 

• I want to specify a custom size for images to stitch: choose the desired size of the resulting 
export image. Be aware that, for larger images, there is a memory restriction that comes from the 
operating system and hence, this operation may not work if a system is low of memory;  

• Mark Crop Area: it marks the contour of the region on the final image; you can select its color; 

• Scale bar: please see Chapter 4.1.2 of the current manual; 

• Include Categories: in this case, the selected categories will appear on the final image. 
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Here the user can choose the categories to be included in the region overview image, by pressing the 

browse button ( ). 

 

- In the selection list, only those categories will be listed that contain regions on their 
overview image. 

 

 

Figure 285 – Export Region Overview: Categories included  

 

• Opacity of the categories: adjust the Opacity parameter, in order to choose the transparency of 
the tissue area name that appears on the region. 

• Apply Illumination Correction: this option is enabled only for Brightfield experiments. The 
correction image will be applied to exported images if the correction image is available. 

 

Restrictions regarding the images to be exported: 

- For all export formats (excluding tiff with multiple tiles) the image size must not exceed 
80000000 pixels. 

- For tiff with multiple tiles the uncompressed size must not exceed 2000 Mb. 

 

Export Overviews from Categories 

To export categories, first check Export only overviews from categories. You should also select the 

types of categories to be exported, by pressing the  button. The following dialog will appear, listing 
the available categories: 

 

Figure 286 – Export subregions: Select categories 
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In the lower part of the Export Region Overview dialog you will now see a section including all the 
overviews that will be exported. For each overview the name and the image size is displayed. 

 

Figure 287 – Export Region Overview: export subregions  

6.19.3 Export One FOV Image 

You can access this option by pressing the Export button from the One Image Viewer toolbar. 

 

Figure 288 – One Image Viewer toolbar 
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The following dialog will appear: 

 

Figure 289 – Export single FOV Image  dialog 

 

• Select the storage folder; 

• Select files to be exported:  

- Images 

- Movies (option available only if the region was acquired with time lapse) 

- Use stitch 

• Select the file name convention (Name Parts, Custom Part, Parts, Image Format, Name 
Preview); 
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• Select the type of images you want to save: 

- Overlay: the image as it appears in the One FOV Viewer. 

- Original: the images for each channel as acquired. 

• Mark Crop Area: it marks the contour of the shape for each FOV; you can select its color; 

• Scale bar: please see Chapter 4.1.2 of the current manual; 

• Apply Illumination Correction: this option is enabled only for Brightfield experiments. The 
correction image will be applied to exported images if the correction image is available. 

6.19.4 Export current Slide Image 

To export a slide’s preview image, select Export slides images… from: 

• Stage control menu 

 

Figure 290 – Stage control context menu 

• Slide editor menu 

 

Figure 291 – Slide editor context menu 

• Experiment editor menu only on experiment item 
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Figure 292 – Export slides images from Experiment editor 

 

No matter from where you access this option, the following dialog will appear: 

 

Figure 293 – Export this Slide Image dialog 

• Select the storage folder; 

• Select the file extension; 

• Include regions checkbox – you can choose if the export image should contain or not the region 
shapes; 

• Scale bar: please see Chapter 4.1.2 of the current manual. 

6.19.5 Export Annotations 

To export annotations, go to the region viewer toolbar, choose Subregions button → Export Annotations. 
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Figure 294 – Subregions contextual menu: Export Annotations 

The following dialog will appear: 

 

Figure 295 – Export Annotations 

The first step to export is to select desired item(s) from the list. 

You can also select desired items by using the buttons in the right side of the dialog: 

• Select by area 

• Select by length 

• Select all 

Now press Export button and choose in the browser that opens the location folder and specify the 
name for the csv file to be exported. Finally, press Save button to finish the export. 

The exported csv file will contain the following data: 

• Experiment name 

• Slide name 

• Region name 

• Annotation name 
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• Area/Length 

• Unit measure 

• Description (if any) 

6.20. Use Plugins 

A plugin is a software program that extends another program’s functionality without the necessity of 
reinstalling the main program. For TissueFAXS, the following plugins are provided by default: 

Plugins for Brightfield experiments 

• Launch HistoQuest for entire experiment from Analysis → Launch HistoQuest…; 

• Launch HistoQuest for the current region displayed in region viewer from Plugins → Analysis 
→ Launch HistoQuest…, in region viewer. 

In both cases above, all version of HistoQuest (starting with HistoQuest 1.0.2.0210) will 
automatically import corresponding data from TissueFAXS. 

Plugins for Fluorescence experiments 

• Launch TissueQuest from Analysis → Launch TissueQuest…; 

• Launch TissueQuest from Plugins → Analysis → Launch TissueQuest… in region viewer. 

In both cases above, TissueQuest will start. 
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7. TMA Support 

Although the TMAs can be treated and acquired as regular regions, TissueFAXS offers enhanced 
support for this type of samples/slides, in order to facilitate your work and obtain high quality results. 

In order to define TMA blocks and spots on a slide, the content type of the slide must be set to TMA.  

 

- It is not possible to set the content type of a slide if the slide contains any regions or 
groups. 

 

 

Figure 296 – Setting the content type of the slide 

7.1. Automatic detection of TMA structures 

TissueFAXS provides automated tissue detection for TMA structures. By using this feature, the 
efforts of working with TMAs will be considerably reduced. 

It consists in an algorithm based on contrast and uniform illumination. Therefore, applying the 
illumination correction before detection of the TMA spots might be needed. You can do this by using 

Illumination Correction button (  ) from Slide Preview toolbar. 

After applying the illumination correction, TissueFAXS can automatically detect the TMA structures 
on a slide.   

Start by pressing the Tissue Detection button ( ) from Slide Preview toolbar.  

When the automatic detection of TMA structures is initiated, the dialog below will appear. In this 
dialog, the user can restart the TMA detection using different parameters. This operation can be done 
for the whole slide or over a specific selected area.  For best results, the area selected for detection 
should contain mostly tissue. The coverslip borders and other artifact structures should be avoided.    
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Figure 297 – Automatic detection of TMA structures panel 

 

Parameters 

In order to refine the results of the automatic detection of TMA structures, TissueFAXS provides a set 
of parameters that can be adjusted according to your needs, in order to obtain the desired results. 

Background: Use this to eliminate the high background and ununiform illumination. Its value should be 
equal to the average size of the spot radius.  

Median filter: Use this to improve detection when images containing some artifacts have to be used for 
detection. Basically, the algorithm will ignore the pixels brighter/darker than the medium value. 

Background threshold: It is best to set this to auto. You might want to try this when the spots are 
clearly visible on the background and the detection fails to return the best results. This parameter 
represents a medium value between background maximum intensity and spots minimum intensity. 

When TMA structures are adequately detected, press the OK button. 

Place Holders 
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The place holders are virtual TMA spots which replace missing tissue from some positions on the 
matrix structure of the TMA block. In the image below, the place holders appear in dark green. 

 

Figure 298 – Place holders 

 

For a TMA spot to be considered a place holder, go to the property editor and set the value Yes in 
the Placeholder option. 

 

Figure 299 – Place holder property 

 

 

- The automatically detected empty spots already have this property set to True value. 

- The place holders are not included in the acquisition process. 

 

7.2. Manual definition of TMA structures 

In order to manually define the TMA structures on a slide, the slide must already have a preview 
image and the content type of the slide must be set to TMA. 
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7.2.1 Definition of TMA block size 

 

The first step in the manual definition of TMA structures is to indicate the size of a TMA block (the 
number of rows and columns). 

You have two possibilities when defining the size of a TMA block. 

• Press the left mouse button on TMA Block Size button ( ) and drag the mouse down and 
right while holding the mouse button until the desired size of the TMA block is defined. 

 

Figure 300 – Definition of the TMA block size 

• Using predefined size for the TMA blocks, by pressing TMA size button ( ). A dialog will 
appear where the desired number of rows and columns can be set. 
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Figure 301 – TMA block size dialog 

7.2.2 Definiton of the first TMA block on slide 

The first TMA block on a slide is defined by indicating the diagonal between the most upper-left and 
the most lower-right TMA spots of the TMA block. 

To indicate this diagonal, follow the steps below: 

• hold the SHIFT key; 

• press the left-mouse button in the center of the upper-left TMA spot of the TMA block; 

• holding the left-mouse button, drag a diagonal to the center of the lower-right TMA spot in the 
TMA block; 

• when you finish drawing the diagonal, release the left-mouse button and then release the 
SHIFT key. 

This TMA block will become the template for all the other TMA blocks having the same size (the same 
number of rows and columns). 

 

Figure 302 – Manual definition of the first TMA block on the slide 
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7.2.3 Definition of the second TMA block on slide 

The second TMA block on slide is defined by indicating the center of the TMA spot in the most upper-
left corner of the TMA block. 

• hold the SHIFT key; 

• click the left-mouse button in the center of the upper-left corner of the TMA block; 

• release the SHIFT key. 

The second and subsequent TMA blocks will have the same size as the last TMA block manually 
added using the first method. 

 

Figure 303 – Manual definition of the second TMA block on the slide 

7.2.4 Selection of TMA blocks and spots  

The TMA blocks and spots can be selected as below: 

• select an individual TMA spot by clicking on it with the left-mouse button; 

• select an individual TMA block by clicking in the free area between the TMA spots with the 
left-mouse button; 

• select portions of the TMA block by drawing a rectangle that surrounds the desired TMA 
spots and blocks; 

• select multiple TMA spots, by holding  CTRL key; 

• select the entire content of the slide by pressing the CTRL+ A keys. 
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Figure 304 – Multiple selections with 
rectangle 

 

Figure 305 – Multiple selections with 
CTRL 

 

Figure 306 – Select all 

7.2.5 Resize the TMA spots 

The TMA spots can be resized as follows: 

• select the desired TMA blocks or spots; 

• use CTRL+ + keys to increase the size of the TMA spots; 

• use CTRL+ - keys to decrease the size of the TMA spots. 

 

Figure 307 – Resize the TMA spots 
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7.2.6 Rotate a TMA block 

The TMA blocks can be rotated as follows: 

• place the mouse cursor next to the lower-right corner of the TMA block; 

• press the left-mouse button on the blue arc that appears next to the lower-right corner of the 
TMA block and rotate the TMA block using the mouse; 

• release the left-mouse button when finish. 

 

Figure 308 – Rotation of TMA blocks 

7.2.7 Adjust the distance between TMA spots 

The distance between TMA spots can be adjusted as follows: 

• select the desired TMA spots; 

• increase the distance on the X axis using CTRL+ → keys; 

• decrease the distance on the X axis using CTRL+ ← keys; 

• increase the distance on the Y axis using CTRL+ ↓ keys; 

• decrease the distance on the Y axis using CTRL + ↑ keys; 
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Figure 309 – Increase / Decrease the distance between TMA spots 

7.2.8 Moving TMA blocks and spots 

The TMA blocks and spots can be moved as below: 

• select the desired TMA blocks and spots; 

• move the selected objects using the mouse or ←,→,↑,↓ arrow keys. 

7.2.9 Deleting TMA blocks and spots 

The TMA blocks and spots can be deleted as follows: 

• select the desired TMA blocks and spots; 

• press the right-mouse button and select Remove selected items in the menu that appears, 
or press the Delete key. 
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Figure 310 – Delete TMA spots 

7.2.10 View acquired images for TMA spots 

To view the acquired image of a TMA spot, double click on it. 

7.2.11 Grouping TMA spots 

When working with TMAs, it might become necessary to group certain spots within a block (they 
share similar properties, they contain certain types of cells etc.).  So, TMA spots can be grouped as 
follows: 

• select the desired TMA spots; 

• press the right-mouse button and select Group TA Spots in the menu that appears. 
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Figure 311 – Grouping TMA spots 

 

 

- Time Lapse acquisition mode is not available for TMA samples. Therefore, the 
Acquisition Information dialog that appears before acquiring TMAs will display a 
Time Lapse acquisition option disabled and a message that warns the user about 
this fact (see image below). 
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Figure 312 – Acquisition Information dialog: acquiring TMAs 
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8. Print 

Printing your TissueFAXS project will prove to be very useful at some point, especially for the fact 
that the software will not simply print your project, but you will be able to decide which information the 
report has to contain and how the data will be displayed. 

8.1. Print Options 

You have two options to access the Print option and the Print Preview option: 

• By pressing Print ( ) / Print Preview ( ) buttons from the main toolbar; 

• By accessing File → Print or File → Print Preview. 

Printing is only possible for an opened experiment. First, a dialog appears and then items to be 
printed must be selected (acquired items, all items).  

 

Figure 313 – Print dialog: choosing items to print 
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The default selection for this dialog is the selected slide in the slide viewer. It also offers a set of 
options: 

- Draw regions on slide preview: the preview image may also contain region shapes; 

- Show names of regions: this option is available only if the first option is selected; 

- Apply illumination correction to regions: available only for Brightfield experiments, the 
correction image will be applied to exported images if the correction image is available; 

- Show current date: the print date is visible on each page of the report; 

- Show page number: the page number is visible on each page of the report. 

8.2. Print Items 

- If you choose the Print option, a dialog will appear that permits to choose the printer. 

- If you choose the Print Preview option, you will be able to see a preview report. 

 

Figure 314 – Preview report example: first page 

The preview report contains the following: 

• Experiment Name; 

• File Name; 

• Experiment Type; 

• Experiment Description; 

• Product Version: the TissueFAXS version used to print this info; 
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• Location: the location of the experiment; 

• Preview Objective: the objective lens used for the preview operation; 

• Acquisition Objective: the objective lens used for acquisition; 

• Camera: the camera used for this experiment; 

• Each Slide selected in the list: 

- Slide Name; 

- Slide Image; 

- Content Type; 

- Comments: the comments referring to this slide; 

- Objective: the objective lens used for preview. 

• Slide Preview Channels: a table that contains the channel list for the current slide and some 
properties for each channel in the list: 

- Checked: this flag indicates if the current channel is used for overlay; 

- Name: the channel name; 

- Intensity: the channel intensity; 

- Color: the channel color. 

• Region list for each generic slide: 

- Region Name; 

- Region Image; 

- Comments: the comments referring to current region; 

- Acquired: this flag indicates if current region is acquired or not. Two possible values are 
present: Yes or No; 

- Path: the path for current region files; 

- Objective: the objective used for acquire current region; 

- Rows: the number of rows for region; 

- Columns: the number of columns for region; 

- FOV’s Count: the number of FOVs items; 

- Patient Name: the patient name; 

- Patient Reference number: the individual reference number; 

- Time Lapse (if acquired with time lapse); 

- Number of Runs (if acquired with time lapse); 

- Time between Runs (if acquired with time lapse). 

• Regions Channels: a table that contains the channels list for current region and some properties 
for each channel in the list: 

- Checked: this flag indicates if the current channel is used for overlay; 

- Name: the channel name; 

- Intensity: the channel intensity; 

- Color: the channel color. 

• TMA Blocks list for each TMA slide: 

- TMA Block Name; 

- TMA Block Image; 
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- Comments: the comments referring to current TMA block; 

- Acquired: this flag indicates if current TMA block is acquired or not. Two possible values are 
present: Yes or No; 

- Objective: the objective lens used for acquisition of the current region; 

- Rows: the number of rows for the current region; 

- Columns: the number of columns for the current region. 

• TMA Spots Count: the number of spot items. 
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9. Help Menu 

 

Figure 315 – Help menu 

Help – press this button or F1 key in order to open the TissueFAXS User Manual. 

About… - this option will display a splash screen containing the main information about the 
TissueFAXS version in use and also the Disclaimer section (scroll to read). 

 

Figure 316 – About TissueFAXS splash screen 
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10. Modularization 

TissueFAXS application requires license for some of its features that you can find listed below. 

 

- Please note that the behavior of TissueFAXS viewer is not depended on any 
dongle or any other licensing mechanism. 

- Licenses that have a date time as expiry date will be checked each time the feature 
is used. 

- Licenses that have a limited number of uses will be incremented as described in the 
table. In the vast majority of cases, the use counter will be incremented after an 
acquisition is done (with the feature enabled). When we are saying acquisition we are 
taking into account reacquisition also.  When we are saying region we are referring to 
one of the following (based on context): TMA Spot, Normal Region and Time Region.  
So, if we acquire with stitch, same region for 20 times the stitch counter will be 
increased by 20. 

 

Number of fluorescence channels 

Projects created with a higher number of channels will be opened but acquisition will not be possible. 
If the user owns a predefined number of uses, the counter will be incremented after each successful 
or canceled acquisition. The counter will not be incremented if acquisition fails. Checked only at 
experiment creation and acquisition.  

Transmission in fluorescence experiments 

Project created with Transmission in the list will not be acquired. If the user owns a predefined 
number of uses, the counter will be incremented after each successful or canceled acquisition. The 
counter will not be incremented if acquisition fails. Checked at experiment creation/acquisition. 

Acquisition of Zstack 

TissueFAXS will not acquire Z stack. If the user owns a predefined number of uses, the counter will 
be incremented after each successful or canceled acquisition. The counter will not be incremented if 
acquisition fails. 

Extended focus 

TissueFAXS will not acquire using extended focus.  If the user owns a predefined number of uses, the 
counter will be incremented after each successful or canceled acquisition. The counter will not be 
incremented if acquisition fails. 

Acquisition of time-lapse regions 

TissueFAXS will not acquire snapshots, but will open already acquired projects. If the user owns a 
predefined number of uses, the counter will be incremented after each successful or canceled 
acquisition. The counter will not be incremented if acquisition fails. 

Acquisition with stitch and compute stitching 

TissueFAXS will not acquire with stitch or recomputed stitch for regions. Older projects will be properly 

displayed. If the user owns a predefined number of uses, the counter will be incremented each time 
stitch is computed manually or automatically through the acquisition. 

Acquisition of TMA 

TissueFAXS will not acquire TMA Spots, but will allow opening existing projects. If the user owns a 
predefined number of uses, the counter will be incremented each time a TMA spot is acquired. 

Acquisition of well plates 

TissueFAXS will not acquire Well Plates, but will allow opening existing projects. If the user owns a 
predefined number of uses, the counter will be incremented each time a region on a Well Plate is acquired. 

Tissue Detection 
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TissueFAXS will not allow running Tissue Detection. If the user owns a predefined number of uses, the 
counter will be incremented each time Tissue Detection is runned. 

Illumination Correction 

TissueFAXS will not allow acquiring/setting the illumination image. If the user owns a predefined number of 
uses, the counter will be incremented each time the correction images are applied. 

Burst mode for Baumer during focus and acquisition 

TissueFAXS will not allow the use of burst mode during acquisition/focus. If the user owns a predefined 
number of uses, the counter will be incremented after each successful or canceled acquisition. The 
counter will not be incremented if acquisition fails. 

Correction flags 

TissueFAXS will not allow the use for flags. If the user owns a predefined number of uses, the counter 
will be incremented after each successful or canceled acquisition. The counter will not be incremented if 
acquisition fails. 

Load settings from file 

TissueFAXS will not allow loading settings from project. If the user owns a predefined number of uses, 
the counter will be incremented after each load. 

Load settings from profile 

TissueFAXS will not allow loading settings from profile. If the user owns a predefined number of uses, the 
counter will be incremented after each load. 

Camera profiles 

TissueFAXS will not allow loading settings from profile. If the user owns a predefined number of uses, the 
counter will be incremented after each load. 

Build cache for acquired regions 

If license is not present, TissueFAXS will not display/compute the cache and it will use thumbnails only. If the 
user owns a predefined number of uses, the counter will be incremented after each build. 

Export FOV images 

TissueFAXS will deny export if license is not present. If the user owns a predefined number of uses, the 
counter will be incremented after each region export. 

Export Region Overviews 

TissueFAXS will deny export if license is not present. If the user owns a predefined number of uses, the 
counter will be incremented after each region export. 

Export movie for time-lapse 

TissueFAXS will deny export if license is not present. If the user owns a predefined number of uses, the 
counter will be incremented after each region export. 

Export of XML files 

TissueFAXS will deny use of plug-in based on dongle. If the user owns a predefined number of uses, the 
counter will be incremented after each export. 

Import regions from XML files 

TissueFAXS will deny use of plug-in based on dongle. If the user owns a predefined number of uses, the 
counter will be incremented after each export. 

Export to Definiens 

TissueFAXS will deny use of plug-in based on dongle. If the user owns a predefined number of uses, the 
counter will be incremented after each export. 

Acquire raw data images 
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TissueFAXS will not save raw data during acquisition. If the user owns a predefined number of uses, the 
counter will be incremented after each successful or canceled acquisition. The counter will not be incremented 
if acquisition fails. 

Measure Tool 

TissueFAXS will not allow the use of measure tool. If the user owns a predefined number of uses, the 
counter will be incremented after each use. 

Print Module 

TissueFAXS will not allow the use of print module. If the user owns a predefined number of uses, the 
counter will be incremented after each use. 

Role-based administration 

No settings will be hidden based on user role. If the user owns a predefined number of uses, the counter 
will be incremented after each login. 

Estimate and display duration 

No estimation will be displayed. If the user owns a predefined number of uses, the counter will be 
incremented after each successful or canceled acquisition. The counter will not be incremented if acquisition 
fails. 

Move the Z axis on filter change 

Z drive will not move when changing filters. If the user owns a predefined number of uses, the counter will 
be incremented after each successful or canceled acquisition. The counter will not be incremented if acquisition 
fails. 

Different Attenuator settings for channels 

Attenuators settings will be ignored when moving from filter to filter. TL Lamp settings will be ignored. 
If the user owns a predefined number of uses, the counter will be incremented after each successful or 
canceled acquisition. The counter will be incremented if acquisition fails. 

If the user does not have a license for a certain feature, TissueFAXS will display an informative 
message: 

 

Figure 317 – Example of License Message 
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11. Appendix 

1. Actions � Beep After Acquisition   

� Shut Down After Acquisition  

� Acquire Correction Image  

� Build Cache Mode  

� Use Default Cache Action For Regions Without Cache  

� Default Cache Action  

2. Measurements � Scale Bar Color  

� Scale Bar Location  

� Measure Color  

� Measure Unit Of Measure  

� RGB Color 

3. Remember � Do Not Show Preview Focus  

� Do Not Show Reset Focus Point For Preview  

� Do Not Show Slide Renaming  

� Time Lapse Acquisition  

� Time Lapse Runs  

� Time Lapse  

� Send Email After Acquisition  

� SMTP Server  

� Email Address 

4. Support � Name  

� From Address  

� Auto Save Report  

5. Preview � Preview Schema  

� Label Position  

6. Storage � File Name Convention (each part)  

� Parts Separator  
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� Image Format  

� Store Each Slide In Directory  

� Store Each Region In Directory  

� Default Directory  

� Save Raw Data  

7. Scan Strategy � Use Enhanced Camera Mode   

� Force Maximum FOVs Number  

� Forced FOV Rows  

� Forced FOV Columns  

� Focus Only Once Per TMA Spot  

8. Stitching � Enable Stitch  

� Use Internal Stitch  

� Overlap Width  

� Overlap Height  

� Compute Stitch Mode  

9. Focus � Focus Algorithm  

� Rough Focus Measure, if HP - X,Y, HP Fine - X, Y, Fidelity  

� Fine Focus Measure, if HP - X,Y, HP Fine - X, Y, Fidelity  

� Focus Strategy Neighbors   

� Focus Points  

� Always Force Full Focus  

� Enable Focus Validator  

� Focus Validator Maximum Allowed Score  

� Focus Validator Fidelity Of Details  

� Override Defaults Focus Intervals 

� Upper Z Position  

� Lower Z Position  

� Use Refocus Distance  

� Refocus Distance  
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� Use Camera Partial Scan  

� Width Percent For Partial Scan  

� Height Percent For Partial Scan  

� Use Enhanced Camera Mode  

10. Advanced Focus � List Reflector, Extended Focus Method, Save Z Stack  

� Use Extended Focus  

� Save Z Stack  

� Steps Above  

� Step Size Above  

� Steps Below  

� Step Size Below  

11. Camera Manager � Camera  

12. Stage Manager � Selected Stage Configuration  

13. Default � Load Default Profile Automatically  

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 


